Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Ctrl+E,D to arrange my codes in VS 2008 (C#),
Some days ago I installed a C# component, since then Ctrl+E,D doesn't work anymore!

How I can fix it so it works again?

share|improve this question
    
Which C# component, if it seems linked to that? –  Gnoupi Jan 25 '10 at 8:24
add comment

3 Answers

up vote 3 down vote accepted

You can customise the Autoformat key chord.

Tools, Customise, "Keyboard..."

Then enter customise "Edit.FormatSelection" for the default editor scheme;

Options dialogue

share|improve this answer
    
Great, Thanks a lot. –  Mohammad Jan 31 '10 at 11:22
add comment

Auto formatting?

Ctrl+K,Ctrl+F

Or

Edit -> Advanced -> Format Selection
share|improve this answer
    
Thanks, What about Ctrl+E,D . How can I restore it ? because I accustomed to it ;) –  Mohammad Jan 25 '10 at 9:33
    
Tools, Customise, Keyboard, select default scheme, enter "Edit.FormatSelection", add shortcut key. I'll add another answer with a picture ^^ –  RJFalconer Jan 30 '10 at 22:47
add comment

To restore the old keyboard mapping, go to Options->Environment->Keyboard->Apply the following additional keyboard mapping scheme and choose Visual C# 2005

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.