Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP (Home) machine with a very weird problem. I cannot set the background image properly. That is, I can go to Desktop, Background image, select a different one, but the background has still the same solid colour. Now if I kill explorer.exe, I can see the background image correctly, but starting explorer.exe gives me the solid colour background back again.

If I go to Desktop, Customise Desktop, Web, there is a checkbox at the bottom called "Fix desktop icons" or something like this (not sure how it's called in the English version.) If I enable this checkbox, I can see the background, but the desktop icons are drawn with solid-colour backgrounds (even though I have the "draw icon labels transparently" option set.) If I disable the checkbox, I have no desktop background. Active Desktop is disabled.

Any idea how to fix this and what might be the reason for this behaviour in the first place?

share|improve this question
    
Drivers are up to date? –  jay Feb 28 '10 at 10:04
    
Graphics driver software might be overriding Windows with its own background specification? –  mindless.panda Mar 3 '10 at 15:45

2 Answers 2

up vote 10 down vote accepted
+150

In the same dialog box that you mentioned about the "fix desktop icons" button, ensure that active desktop isn't enabled by unchecking everything in the list.

alt text

Next, go into the Registry Editor and check that there is not a key called 'NoChangingWallpaper' in either of the following locations. If there is, delete it and restart.

  1. Click Start
  2. Click Run
  3. Type regedit
  4. Click OK

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop and HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

Try resetting the Windows theme:

  1. Right-click your desktop
  2. Click Properties
  3. Click the Themes tab
  4. Select Windows XP from the list of themes
  5. Click Apply
  6. Restart your computer

alt text

Failing that, try an sfc /scannow to check for any corrupt system files they may be preventing the desktop wallpaper from automatically refreshing.

  1. Pop in your XP installation media and cancel out of the installation wizard
  2. Click Start
  3. Click Run
  4. Type sfc /scannow
  5. Click OK
  6. When the box disappears, restart your computer

alt text

If this does not work, try a system restore.

share|improve this answer

how about deleting a file from the registry that is restricting it.

share|improve this answer
1  
I'd be a little more inclined to upvote this if you gave a little more detail. –  KronoS Apr 8 '13 at 17:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.