Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a hard drive that gets plugged into several machines. One MacBook Pro running Mac OS X, some Ubuntu and Fedora Installations and sometimes Windows XP or Vista. Therefore, I formatted it NTFS to be able to read and write on it no matter which machine is used. On Mac OS I installed MacFUSE to do this.

The Problem is, when the USB device is removed from a Windows box, without using the "remove hardware" function from the task bar, the drive is locked. When I wnat to mount it in Mac OS, I get an error message and have to connect it to back to Windows and cleanly unmount it.

So, my question is: Is there an easy way to use the drive on every computer / OS without mounting problems?

share|improve this question
It doesn't help you right now, but I've been using the Paragon NTFS driver daily for a little over a year, backwards and forwards between Macs, Windows XP and Windows 2k3 and haven't had a problem opening 'unsafe removed' external drives and usb keys - even when I've had the 'unsafe remove' message a couple of times. – robsoft Jul 28 '09 at 12:00
up vote 3 down vote accepted

The latest version of NTFS-3G for Mac allows you to force mount the disk, even when it wasn't disconnected properly.

share|improve this answer
That are great news! Thanks buddy. – Tim Büthe Jul 29 '09 at 11:17

You'll have to have a Windows system handy to have unlocked. That's the only way I've heard of fixing this issue.

On a related note, unsafely removing a drive from MacOS X can lead to locking, for which I could not find a Mac-native solution. That was hell in a handbasket to fix.

share|improve this answer

On Linux you can mount a locked drive by using the force option (mount -f). This should work on OS X as well, but I've never tried it.

EDIT: ntfsfix (comes with ntfsprogs) will unlock the drive. ntfsprogs should be available on all Linux computers, and I believe it is available in macports.

share|improve this answer
I've tried, and it doesn't work on NTFS drives, even if you have software installed to let MacOS read directly from the drive. – Andrew Scagnelli Jul 21 '09 at 20:32
"mount -f" is kind of dangerous, isn't it? I don't want to risk any data loss. – Tim Büthe Jul 22 '09 at 6:58
"mount -f" doesn't work (see A. Scagnelli's comment), but ntfsfix should work. – starbuck Jul 22 '09 at 14:32

You should use FAT32 if you're moving it between operating systems. All the major OS's have full read/write support for FAT32 without the need for third party software or silly tweaks like the one you're requiring here.

share|improve this answer
Fair point but it depends on the kind of information he's moving around - there's a small filesize limit on Fat32 (4Gb?) which can be a pain when you're moving around large disk images, VMs etc. – robsoft Jul 28 '09 at 11:58
I have a 120GB usb harddrive that is formatted as FAT32. Works very well... – Jasarien Jul 28 '09 at 12:07
Yes, like robsoft said, Fat32 is old and limited. I want to move virtualbox machines or DVD-Images without splitting them or something like this... – Tim Büthe Jul 29 '09 at 11:19

You should really unmount your drive properly.

The reason why you need to do that is Windows write-caches for that USB stick, so it may say it's done writing files to yoru app, to make it more responsive, but it could still be hard at work finishing the job.

If you remove the stick before that's done, you lose data, and it's for your data's protection that it is doing that.

share|improve this answer
You're right, but the described Problem also occurs, if you haven't written to the device at all. Just Plug it in and out again. – Tim Büthe Oct 12 '09 at 7:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .