Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am facing an issue with memory allocation.

I have:

Host OS: Microsoft Windows XP - Professional x64 Edition - Version 2003 - Service Pack 2.

Host Physical Memory: 8 GB

Guest OS: Red Hat Enterprise Linux WS release 4 (Nahant Update 5). I am not sure if it is 32 or 64 bits. The lsb_release -a command says that argument LSB Version: core-3.0-ia32, so I guess that would be 32 bits...

VMware Player Version: 2.5.2 build-156735

I would like that VMware Player could allocate more that 4 GB, but when I go to the setting, it only lists 4 GB. If I choose the "About" option, it actually says that I have 8 GB installed in the host machine.

This VMware image created by someone else and provided to me, apparently done with VMware Workstation 5.

Why can't I allocate 8 GB?

Where is the problem?

In the WMware Player Version, Guest OS or Host OS?

How can I solve this?

I understand that for this version of player there isn't one version for 32 and another for 64 bits.

share|improve this question

migrated from serverfault.com Jan 25 '10 at 18:29

This question came from our site for professional system and network administrators.

    
Might want to re-edit the title to "Allocate more than 4Gb of memory to VMWare Guest" –  Avery Payne Jan 25 '10 at 20:30

5 Answers 5

The lsb_release -a command says that argument LSB Version: core-3.0-ia32, so I guess that would be 32 bits...

Try uname -a and look at the resulting output. If you see x86_64 then yes, it's 64-bit.

I would like that VMware Player could allocate more that 4 GB, but when I go to the setting, it only lists 4 GB. If I choose the "About" option, it actually says that I have 8 GB installed in the host machine.

This VMware image created by someone else and provided to me, apparently done with VMware Workstation 5.

Older images have limitations that are inherent to them, based on what version they were made with. It could be as simple as the fact that the image was made in version 5; newer versions lift several limitations, and one of those might be the amount of memory supported. For instance, I run 6.5 at work, which allows 2 CPUs. Version 7 allows for 4.


Follow-up:

My Workstation 6.5 install reports that a version 5 image will have the following limitations:

  • 3.5 GB memory limit
  • 2 processor limit
  • 3 network adapter limit
  • No USB 2.0
  • No multiple monitor display
  • No battery status
  • No CPU hot plug
  • No device hot plug
  • No memory hot plug
  • No LSI Logic SAS SCSI adapter
  • No VMCI support

In other words, you're not going to get it to run with 8 GB because it's a version 5 image. You'll want to consider migrating the machine to a newer format.

share|improve this answer

Can you try downloading the free 'VMWare Server', see how you get on with that, it should offer a lot more options.

share|improve this answer

I think that VMware server (and Workstation and Fusion) only allow you to allocate up to 4 GB as a limitation of the tool. ESX certainly does not have the limitation, though.

share|improve this answer

The command uname -a would show you your kernel info and help you determine if it's a 32-bit OS (x86) or 64-bit (x86_64).

As for your question regarding the allocation of more than 4 GB of memory...well, maybe someone can correct me if I'm wrong, but I do believe that VMWare would limit memory allocation based on your OS and if indeed your RHEL is 32-bit, then the 4 GB cap would make sense.

share|improve this answer
    
Don't see how VMWare could determine whether the guest is 32/64bit... –  fahadsadah Jan 25 '10 at 16:26
    
Maybe not VMWare as such but that particular product isn't supposed to be too feature-rich so it could easily be what's at fault. –  Chopper3 Jan 25 '10 at 16:26
2  
VMware does know what the guest is. It has to in order to provide the proper virtual bus etc... If you look at the settings on a VM, you will see what vmware thinks it is. –  Scott Lundberg Jan 25 '10 at 17:47
    
Not only does VMware know if the guest is 32/64 bits, but it will (at least in 6.0/6.5) block a 32-bit host from running 64-bit guests. –  Avery Payne Jan 25 '10 at 19:30

As per this post on vmware.com If found this solution here: http://communities.vmware.com/thread/332104

  • First you need to determine if the VM is 64bit.
  • Then you need to change the VMWare vmx file to support a higher virtual hardware version.

On the Guest use uname -a to determine if the Linux VMWare guestif 64bit. E.g mine is 3.4.2-1.fc16.x86_64. The 64 at the end tells you it's 64bit.

On the Host edit the .vmx text file in a text editor: - Change virtualHW.version="8" (I suspect it's currently 5 as you said the VM was created with VMWS v5.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.