Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows XP Professional x64 and IIS 6.0. I have been tasked with making some code changes to a classic ASP application. I've created a virtual directory under iis. I get the following message when I try to browse to the site.

You are not authorized to view this page The URL you attempted to reach has an ISAPI or CGI application installed that verifies user credentials before proceeding. This application cannot verify your credentials.

I'm checking the production server to identify this issue and I'm thinking it's related to the framework setting. It is set to 2.x on my local 64 bit machine and the 1.x version does not appear in the dropdown list. I've installed 1.x on the machine, but now the asp.net tab no longer appears. I did some research on how to get the tab to reappear, followed the recommendations. The tabl now appears, but 1.x framework is still not listed.

Any suggestions are greatly appreciated. Are there command line arguments to tell the IIS to run this site under the 1.x framework since I can't seem to do it from within IIS?

Randy

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You have to switch to 32bit mode, like this: http://support.microsoft.com/kb/894435 It is per-process, so you will not be able to run other web applications in 64bits.

share|improve this answer
    
That is the article I found and I ran those steps. Now I don't have an ASP.Net Tab to switch the app to run under v1.x. I believe it is still trying to run under 2.x. –  Iceman Jan 25 '10 at 21:19
    
I ran into a variety of issues, including needing the FrontPage extentsions. I ended up making a VMWare Image with XP Pro 32bit, setup IIS with the appropriate security, and then installed the Frontpage extentsions. I have it up and running, but now the real fun begins. Thanks, Randy –  Iceman Jan 26 '10 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.