Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got two questions regarding cygwin usage.

  1. I'm trying to run Irssi using Cygwin but it won't connect to any server i give it even if I can connect from other, non-cygwin clients like mIRC and freenode's webchat. The connection always times out and its the same way with other programs (like naim) as well. I can't help but feel that I've missed something, but I don't know what. Do I need to do anything special with Cygwin before I can connect?
  2. I use screen to manage multiple windows, but when I'm using screen with Emacs I can't move to the beginning of a line with C-a because that's captured by screen (c-a 0-9 to move to another window, etc). Is there any way to rebind it?
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted
  1. Are you running Windows' (or another) firewall on your system? Have you created exceptions for Irssi in the firewall control panel?

  2. You can always send Emacs a literal C-a by typing Ctrl-A then A. Screen gets the ^A and the following "a" tells screen to send ^A to the terminal.

    Additionally, there are two ways to change Screen's command character (aka escape character).

    • One-time use: commandline option
      To change the command character for one Screen session, use the -e xy option when starting your screen session. The default is -e^Aa, where x is the command character (^A) and y is the character generating a literal command character (a). If you want your new command character to be ^B, for example, use -e^Bb in your commandline.

    • Personalized default: ~/.screenrc
      To change the command character default, specify it in your ~/.screenrc file. Just add this line to your ~/.screenrc, and your next new session will use the new default command character:

      escape ^Bb
      

      This follows the same xy syntax as the commandline option. You can also use the keyword "defescape" instead of "escape"; they are synonymous.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.