Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows 7, I have (unfortunately) installed Apple Quicktime.

It seems to have decided that it's the chosen application for displaying .png files in Internet Explorer (when clicking on .png links).

I have, however, not set QuickTime as the associated program for .png extensions in the Default Programs control applet in Windows 7. How do I remove QuickTime as the prefered .png viewer?

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

I just stumbled across this solution, which basically involves toggling the QuickTime associations on then back off!

http://sticklebackplastic.com/post/2007/07/05/QuickTime-stealing-file-associations.aspx

share|improve this answer
    
Thanks. I have however uninstalled QT/iTunes. It's amazing how bad the Apple software behaves on Windows. I wonder if it's pure incompetence from the Apple developers or a deliberate decision from managment. My guess it's a little bit of both. –  Magnus Aug 26 '10 at 20:13
add comment

I am in Linux right now so I am doing this from memory.

Open Quicktime and Click:
Edit > Preferences > Quicktime Preferences
There should be an (Association) or (File Types Tab) click it. Uncheck PNG.
If your version has a (Browser) option click it as well and uncheck PNG.
Click every [OK] button you see till you leave Preferences.
Close ITunes.

share|improve this answer
    
Nope, sorry. On Windows 7 (and I'll guess on Windows Vista as well) the Edit-> Preferences->QuickTime Preferences->Browser->"MIME settings"/File Type buttons simply open the Set Program Associations window, on which .png is already unchecked and associated with Windows Live Photo Gallery. –  Magnus Jan 26 '10 at 19:10
    
Ahh sorry I have not used iTunes hardcore since I ditched my iPhone. I was sure the Browser option was the only place to change the browser associations. In IE8 isn't there a file association under it's tools > options? –  Simon Omega Jan 27 '10 at 5:00
add comment

In Windows 7 you go to Start/Default Programs

Select Associate a file type or protocol with a program.

Search the list for the .png extension. Select it and hit Change Program.

If the program you want to use to view .png files isn't shown on that list you can browse to the program you want to use.

I'm not sure if this will actually change the way IE treats .png files but I assume it will.

share|improve this answer
add comment

Okay, I think it's important to explain this problem in better detail, because I am experiencing the same issue! Everyone who answers this type of question has the same answer: go into Control Panel or Quicktime Preferences and change the file association, but the problem is that pngs are not associated with Quicktime in either case.

This problem does not appear to be a problem with file type program associations. This problem is isolated to .png files viewed within Internet Explorer only.

I have tried to go into Control Panel to uninstall the Quicktime plug-in, but all I can find is Quicktime itself. There do not appear to be symptoms or resolutions outside of Internet Explorer itself. The usual resolutions do not work for Internet Explorer either. If I go into "Manage add-ons" in Internet Explorer and disable the add on, the png files are unviewable.

To be clear, the reason why Quicktime controlling .png files in Internet Explorer is a problem is because when I click on a link that leads to a .png image by itself (example: http://www.website.com/pictures/image.png), the image appears in the center of the window (rather than on the left side) and is stuck in a "fit to screen" setting, meaning that I can't enlarge it to its full size. Sometimes the image simply fails to load, showing a broken Quicktime link instead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.