Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's a real doosie; I may just give my firstborn child to whomever helps me solve this problem.

In July 2008, I assembled what would be my desktop computer for graduate school. Here are the specs of the machine I built:

Soon thereafter, I ordered a new motherboard (because I was an idiot; that first motherboard supported CrossFire, not SLI), an Asus P5N-D. I was originally running Windows XP SP3.

Pretty much right into the start of the fall semester, my desktop would simply lock up after awhile. If my system was largely idling, it would be after 1-3 days. If was gaming, it often happened an hour or two into my gaming session, indicating a link to activity level. Here's where it started getting interesting.

  • I started looking at the system temps. The CPU was warmer than it should have been (~60s C), so I purchased some more efficient cooling compound a way better cooler for it. Now it hardly goes over 40 C. Intel was even kind enough to swap it out for free, just to rule it out. Lockups continued.
  • The graphics cards were also running pretty warm: about 60 C idling. Removing one of them seemed to improve stability a little bit...as in, it wouldn't lock up quite as frequently, but still always eventually locked up. But it didn't matter which card I used or removed, the lockups continued.
  • I reverted back to the original motherboard, the P5K Deluxe. Lockups continued.
  • I purchased an entirely new motherboard, eVGA's nForce 750i. Lockups continued.
  • Ran memtest86+ over and over and over, with no errors. Even RMA'd the memory. Lockups continued.
  • Replaced the PSU with a Corsair 750W PSU. Lockups continued.
  • Tried disconnecting all IDE drives (HDDs are SATA). Lockups continued.
  • Replaced both graphics cards with a single Radeon HD 4980. Average temps are now always around 50 C when idling, 60 C only when gaming. Lockups continued.
  • Throughout the whole ordeal, the system has been upgraded from Windows XP SP3 to Vista 32-bit, to Vista 64-bit, and is now at Windows 7 64-bit. Lockups have occurred at every step along the way (each OS was in place for at least a few months before the next upgrade). Edit: By "upgrade" I mean clean install each time. In addition to those reformats, I have performed many, many other reformats of the system and a reinstall of whatever OS had been previously installed in an attempt to rectify this problem, to no avail./Edit

When the system locks up, there's no blue screen, no reboot, no error message of any kind. It simply freezes in place until I hit the reset button. Very, very rarely, once Windows boots back up, the system informs me that Windows has recovered from an error, but it can never find the source aside from some piece of hardware. I've swapped out every component in this computer, and there are more fans in it than I care to count...though for the sake of completeness:

  • top 80mm case fan (out)
  • rear 80mm case fan (out)
  • rear 120mm case fan (out)
  • front 120mm case fan (in)
  • side 250mm case fan (in)
  • giant CPU fan
  • on-board motherboard fan (the eVGA board)
  • triple-fan memory setup (came with the memory)
  • PSU internal fan
  • another 120mm fan I stuck on the underside of the video card to keep hot air from collecting at the bottom of the case

I'm truly out of ideas. ANY help at all would be oh-so-very GREATLY appreciated. Thank you!

share|improve this question

migrated from serverfault.com Jan 26 '10 at 7:46

This question came from our site for professional system and network administrators.

1  
Have you done a CLEAN OS re-install? No upgrades. –  xeon Jan 26 '10 at 0:16
    
This will be migrated to superuser.com shortly. –  Dennis Williamson Jan 26 '10 at 0:17
    
@xeon: Yeah, I need to edit that...by "upgrade" I meant purely in the nomenclature sense. Each "upgrade" was a clean install, and I've reformatted my machine in an attempt to solve this very issue more often than I care to recall. @Dennis: Ahhh, my apologies. Thank you. –  Magsol Jan 26 '10 at 0:21

3 Answers 3

up vote 2 down vote accepted

Have you tried swapping out all the cables?

share|improve this answer
    
As in, the SATA cables? All the power cables were swapped out when I purchased the new PSU, and I tried disconnecting the IDE drives. So that leaves the SATA HDDs...no, I haven't actually tried that. Would that really cause the problem? –  Magsol Jan 26 '10 at 0:19
1  
Unlikely, but "when you have eliminated the impossible...". –  dmo Jan 26 '10 at 0:57
    
Interesting. Swapped out the SATA cables to both HDDs with spares, gamed for an hour, and no lockup. Obviously this will take longer than that to really figure out if that worked, but so far it's promising. –  Magsol Jan 26 '10 at 3:50
    
I've been running my machine basically nonstop since switching out the cables, and gaming as much as I have time for, and there have been no lockups. I'm going to accept this answer, though if the lockups start again then I'll reopen this issue. Kudos on the insight! Still not sure how swapping out the SATA cables could answer the problem of intermittent lockups, particularly when system activity peaks, but I can't argue with the results! Thank you! –  Magsol Jan 31 '10 at 6:01
    
Perhaps when things get hot in the case the expansion of the wires causes some malfunction. In any case - I'm glad your problem is gone. –  dmo Feb 1 '10 at 2:20

I'd consider a power issue. Have you measured the power inputs, or tried a power conditioner or UPS? If the voltage is marginal, heavy use could occasionally trigger an issue.

share|improve this answer
    
I used Everest to measure the voltages, and all the rails were in their proper ranges. I also have the machine permanently plugged into a 75-min battery backup UPS. It certainly isn't definitive, but wouldn't the chances of two separate PSUs having the same problem be pretty remote? –  Magsol Jan 26 '10 at 1:53
    
I'm not suggesting a power issue within the supply, I'm suggesting an (intermittent) problem in power to the supply. However, your UPS makes that unlikely. (You could switch out the UPS. I don't think that's a likely cause, but on the other hand we're out of likely causes.) –  Jon Lasser Jan 26 '10 at 20:52
    
Ahh, I understand. It's entirely possible; I've had this UPS for a few years already. It seems strange that it would only start acting up upon building this new machine (worked fine for a few years before that), but on the other hand, it would coincide with the move across the country to graduate school. Maybe it got banged up? –  Magsol Jan 27 '10 at 1:54

I would think this had to do with either

  • Lack of power
  • Too much heat
  • Faulty memory

For the power I would check in the BIOS to see if the voltages look right and I would get a power meter to see if the computer pulls power which is close to the PSU limit. For the heat, it seems like you should be covered, but just make sure that your computer feels cool. My problem once was that my case lacked circulation so the PSU would just suck in warm air from the case and get really warm. Solved that by adding some fans to suck air through the case. For the faulty memory, I would maybe run a test and try to swap your memory modules out with some new ones if you can.

Other things to try (although they may be kind of obvious so you might already have tried them):

  • Install latest version of BIOS (if you haven't already)
  • Make sure you are using the latest drivers
share|improve this answer
    
At one point I'd had Everest installed and was closely monitoring all the power outputs. I didn't see anything specifically indicating how taxed the PSU was, so do you have any recommendations in that regard? Otherwise, there are certainly patches that feel warmer than others (the video card in particular) but nothing scalding. I've run memtest86 out the wazoo and swapped out modules. I have the latest BIOS installed, and all the latest drivers; since this problem has persisted through different OS's, I don't think it can be a driver issue. –  Magsol Jan 26 '10 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.