Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to share my P:\ drive on a Windows 7 (Pro) PC with other PCs (WinXP) on my network. I shared it and set permissions to give Everyone Full Control.

Symptoms

  • Computer XP(different computer on the network) can access \win7\users\ public (and copy files to it and edit files in that folder) but not the \win7\p:\

  • Folders I've shared on the Windows 7 PC are visible to the XP computers but just not accessible . From the other WinXP PCs on the LAN accessing the Win7 PC, I get "win7\p not accessible. You might not have permission to use the network resource. " "Access Denied".

Edit: I've to Advanced Sharing options set to have the following enabled:

  • Network Discovery
  • File and Printer sharing
  • Sharing so anyone can read/write files to public folders.
  • 128 bit encryption (perhaps this is an issue? Perhaps it should be set to 40 bit encryption?)
  • Allow Windows to manage homegroup.
  • XP machines are set to not use Simple File Sharing.

Other Things I've Tried

  • Confirmed all computers are in the MSHOME workgroup.
  • Turned off the Windows 7 Firewall, briefly. Problem persisted.
  • Tried the Windows 7 Network Troubleshooter. Just led me around in a circle saying "found problem...need more information". The links from there led back to the Network Troubleshooter.
  • tried disabling the Firewall on the Windows XP machine. No joy.
  • Verified the XP machines are both on Win XP SP3 and both have "download updates" turned on.
  • Installed IE8 on the XP machine1. (Previously it had IE 6). Still no joy.

Any ideas?

share|improve this question
    
Curious: Are you sharing the ROOT of P:? Or a subfolder? –  tcv Jan 29 '10 at 18:27
    
And also: What is the SECONDARY error within the dialogue. For instance, it may be "Access is Denied" or "Unknown username or bad password." –  tcv Jan 29 '10 at 18:39
    
@tcv : I'm sharing the root of P: and the secondary error is "Access Denied" –  Clay Nichols Jan 29 '10 at 23:43
    
Ok, I can duplicate that with my 7 workstation. Curious: What happens if you share a subfolder. I've seen this problem before in Vista and I'll have to flog myself to remember what I did... –  tcv Jan 29 '10 at 23:55

6 Answers 6

up vote 3 down vote accepted
+150

Try this on the Windows 7 machine:

  1. Open Administrative Tools -> Local Security Policy.
  2. Click on Local Policies -> User Rights Assignment on the left.
  3. Double-click "Deny access to this computer from network".
  4. Select Guest and click Remove.
  5. click OK.
  6. EDIT: Ensure in the Permissions for the network share, that Guest is included, since it's no longer part of the Everyone group.
  7. Use regedit to go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System and create or modify the value of LocalAccountTokenFilterPolicy (32-bit dword) to 1, so the remote logon token will not be filtered (see here).
share|improve this answer
    
There were no Users listed in that field (i.e., Guest had never been added) –  Clay Nichols Jan 29 '10 at 17:45
    
@Clay Nichols: See my edit. –  harrymc Jan 30 '10 at 17:58
    
I'll try that. BTW, That fix says it's for allowing another computer to access Vista if they are on different domains. We don't use domains we use Workgroups and they're all on the same workgroup. –  Clay Nichols Jan 30 '10 at 18:42
1  
@Clay Nichols: Thanks for the points. For the benefit of future : Which one worked? –  harrymc Jan 31 '10 at 10:24
1  
@harrymc: Resolved after I did #4,5,6 on the Windows 7 machine. –  Clay Nichols Feb 1 '10 at 19:03

Go to Network and Sharing Center then click on Advanced sharing settings.

Make sure that File and printer sharing is set to on and Password protected sharing is turned off.

Then when you access the machine from the network, it should work - if you still have problems, write in comments and I will try to help further.

share|improve this answer
    
I've got that set already (I should have included that in the question). –  Clay Nichols Jan 27 '10 at 22:47
    
And, of course, still having the problem. Any suggestions? –  Clay Nichols Jan 29 '10 at 6:35
    
Try to press alt in any folder and go to tools > Folder Options. Under view uncheck "use simple file sharing". Then, on the folder, as well as having everyone selected for full control or whatever, make sure in the seporate security tab you have done the same. Network logons try to use guest and this does not have control by default. –  William Hilsum Jan 29 '10 at 9:26
    
Wil - I assume 'turn off Simple.." is for the XP PCs? They are already set to NOT use Simple Sharing. –  Clay Nichols Jan 29 '10 at 17:47
    
This is for the 7 machine as it does some various registry and policy changes re: guest account and network permissions. –  William Hilsum Jan 29 '10 at 20:40

Also, there was an update for Windows XP a few months ago, which is needed to be able to connect with new versions of windows. check in windows update center, if you have all updates + service pack 3 installed.

share|improve this answer

I tried all of the steps mentioned, but finally fixed my own issue:

  • Right-click the drive and select Properties (drive or any folder you want to share)
  • Select the Security tab
  • Click [Edit]
  • Add Everyone to give full control to all users
  • Apply

It works great for me now.

share|improve this answer

Try adding a user(administrator) with same name and password on the xp and windows 7 machine.

share|improve this answer
    
I suspect this might work as well if we're using Simple Sharing, but I've not tested it. –  Clay Nichols Jan 31 '10 at 4:00

This is a workable but ugly workaround:

  • Change the user account type to administrator and set a basic password, "pass" for example.
  • When my XP machine asks for username and password I type [computername]/[admin user name] and the password you set.

This allows you to log into the machine although it may not be great for all occasions (and have security side effects)

share|improve this answer
    
It works also with less priveedged guest accounts. –  eckes Dec 13 '12 at 3:03

protected by Community Jun 19 '11 at 17:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.