Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to revitalize an old Thinkpad R31 that has the Intel 82830 graphics and only 256 MB of RAM.

I have tried a Xubuntu 9.10 Live CD. After booting the screen blinks so much that it is practically unreadable.

I have searched for updated IBM Thinkpad drivers but I only found drivers for Windows on the Thinkpad support web site.

EDIT: I have changed the title and the description. It is not a problem of the drivers. It seems to be a problem with the kernel. See my own answer below.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I have collected more information, and I solved my problem.

Here http://ubuntuforums.org/showthread.php?t=1318523 is an exact description of the very same problem

And here http://ubuntuforums.org/archive/index.php/t-1307879.html is an explanation of a possible answer

essentially the problem is a conflict of the intel 830 driver and Kernel probing, which is enabled by default since Kernel 2.6.30-10.12 ( see this link https://wiki.ubuntu.com/X/KernelModeSetting )

So, the solution to the screen problem is disabling Kernel probing by setting the option i915.modeset=0 in the kernel boot command line.

But, this leads to another different problem.

As documented in some web sites, this fix is accomplished by adding the option in /boot/grub/menu.lst

But, there is no /boot/grub/menu.lst in my xubuntu 9.10 .

Looking further, I found /boot/grub/grub.cfg instead.

grub.cfg has a big warning in its header DO NOT EDIT THIS.

The grub.cfg header documents that the grub.cfg file is generated from /etc/default/grub.

So following this path, I came up with the solution


  1. I modified /etc/default/grub adding i915.modeset=0 to the default linux boot GRUB_CMDLINE_LINUX_DEFAULT

  2. Then I regenerated grub.cfg with update-grub


And .. it works.

share|improve this answer
    
as no one has answered or commented my answer, I am accepting it. –  PA. Jan 28 '10 at 10:20
add comment

This worked perfectly to eliminate the flashing external display problem on my ThinkPad R31 running Xubuntu 12.04.2

When changed, the actual line in grub was (note the quotes):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=0"

Thanks!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.