Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to RDP from a Windows 7 Professional dual monitor physical machine to a Windows 7 Professional VM hosted on esxi 4.0.

I can get the spanning option to work to both monitors, but I have tried 3 different methods of connecting but have not been able to use true multiple monitors.

At different times, I tried checking the "use all monitors" option, command line mstsc /multimon and added the line use multimon:i:1 to the .rdp file. None of these worked. Any ideas? The physical machine can connect to other Windows 7 physical machines with true multi monitor access.

I also have the same issue when going from a 32-bit RC1 machine to a Windows 7 Professional 64-bit, but not when going in the reverse direction. Here's the .rdp:

screen mode id:i:2
use multimon:i:1
desktopwidth:i:1440
desktopheight:i:900
session bpp:i:16
winposstr:s:0,1,341,118,1139,568
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:1
displayconnectionbar:i:1
disable wallpaper:i:1
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:1
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:192.168.1.5
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectdirectx:i:1
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
use redirection server name:i:0
drivestoredirect:s:
share|improve this question

1 Answer 1

up vote 4 down vote accepted

Very, very after the fact, but I saw this had never been answered...

The functionality you're looking for (which normally just requires checking the 'Use all monitors' box) ONLY works if the target machine is running Windows 7 Ultimate or Enterprise (or Windows Server 2008 R2). This is one of the few legitimate differences between Professional and Ultimate.

Note that it doesn't matter what version is on the machine used to manage the remote session, only the target machine (although it needs to be new enough to support this, I think Vista and higher.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.