Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with installing & running Deluge torrent on my Centos 5 (x86) . I get it from http://dag.wieers.com/rpm/packages/deluge/ this: _http://dag.wieers.com/rpm/packages/deluge/deluge-0.5.8.6-1.el5.rf.i386.rpm

after installing, when I run deluge I get this problem:

    Traceback (most recent call last):
  File "/usr/bin/deluge", line 43, in ?
    import deluge
  File "/usr/lib/python2.4/site-packages/deluge/__init__.py", line 36, in ?
    import gtk.glade
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 76, in ?
    _init()
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init
    _gtk.init_check()
RuntimeError: could not open display

No way root I am or user. Same thing. Python version is 2.4.3 . This is server & no X-windows installed on it.

Thanks for help.

share|improve this question
    
I just want to install deluge-core, deluge-webui, deluge-console. –  NARKOZ Jan 26 '10 at 21:10
add comment

migrated from serverfault.com Jan 26 '10 at 21:31

This question came from our site for professional system and network administrators.

3 Answers

up vote 0 down vote accepted

I'd suggest updating both Python and Deluge. Deluge is now on version 1.2.0, miles ahead of 0.5.8.6. I have Deluge (latest) running with Python 2.6.4 smoothly.

Not only does it appear your version is looking for Python 2.4, but it also wants to open a display. Ensure you are using proper command-line arguments for console mode as David outlined. You must first start the daemon before connecting via console. See the Deluge FAQ on the console and daemon.

share|improve this answer
add comment

Upgrade Python. It's looking for version 2.4.

Incidentally, if you have no X-windows then you'll be better off trying rtorrent - a CLI bittorrent client.

share|improve this answer
    
Sorry, I had a mistake. Python's version is 2.4.3. Thank's, but I need only deluge or ktorrent. –  NARKOZ Jan 27 '10 at 20:15
add comment

Assuming you tried to start Deluge like this:

deluge

For a command line based interface you can do this:

deluge --ui null

or:

deluge --ui console

Or for a web-based interface:

deluge --ui web

For more info, see Deluge's FAQ on the topic

share|improve this answer
    
Same thing. Even deluge --version displays that error message. Thanks for reply. –  NARKOZ Jan 26 '10 at 21:23
    
The readme seems to provide some different options. dev.deluge-torrent.org/browser/trunk/README It may be that deluge was linked to deluge-gtk by the RPM. You can try the following options: deluge-console, deluge-web. Or to just start the daemon, deluged. You can look at the README for further info. –  David Antaramian Jan 26 '10 at 23:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.