Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I replaced my processor from Intel Core 2 Duo E8400 to Intel Core 2 Quad Q8200 (both intel64 (x86-64) instruction set) and since then Firefox doesn't start. However firefox -safe-mode does work, which makes me believe that some plug-in is at fault. Firefox crashes randomly with message segmentation fault.

So I'm looking for some command line arguments which I can pass to firefox to make it print messages verbosely and so I can find exactly which plug-in is causing the error.

I'm on Ubuntu 9.10 x64 and so far didn't see any problem regarding the replacement of processor except for Firefox. (Other Mozilla based technologies like Songbird and Thunderbird work perfectly.)

Update (1 hour later): I just simply disabled all extensions in safe mode and enabled them one by one, and now all extensions are enabled again and Firefox is working good now. However, I'm still holding for choosing best answer about how to enable verbose mode for firefox command.

share|improve this question
    
It would help if you supplied a list of extensions you're using, perhaps it's a known issue with one of them –  Ivo Flipse Jan 27 '10 at 12:16

3 Answers 3

command line options can be found http://kb.mozillazine.org/Command_line_arguments and developer.mozilla.org/En/Command_Line_Options

but apparently the -console argument is windows only. Not sure if the lack of debug output launching it from a console on linux is because debug output is disabled for production compilations or some other strange reason.

share|improve this answer

An alternative to the command line option, if one exists, is to simply turn off half of your extensions and restart. If it starts, then you know one of the disabled extensions is to blame, and you can narrow it down from there. If it doesn't start, then one of the still-enabled extensions is to blame; disable half of them and try again. Lather, rinse, repeat. Of course, if it's the interaction of two or more extensions causing the problem, it will be a lot harder to figure out.

share|improve this answer
    
Hi Joe. I remember you from the BoardGameGeek. It's a small virtual world. :) –  Iain Jan 27 '10 at 12:55
    
Small world indeed -- Hi Iain! Like your BGG avatar much better :) –  Joe Casadonte Jan 27 '10 at 14:06

The following bug says that was fixed, however, I also can not run it except as root. https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/546490

Your shortterm purposes, try

sudo firefox -g

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.