Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed windows 7 (dual booting with XP) and after a few days of regular usage I am not able to access the internet anymore.

I am connected through ethernet, and I can access the local network without problems. DHCP seems fine, my ip address, default gateway, and dns server seem normal. I tried setting the info manually just in case but it did not help.

Pinging any host on the local network works fine, pinging anything on the internet can resolve the address but I get no replies. Browsing anything on the LAN work fine but I cannot reach the internet, configuring a proxy on another PC on the LAN seems to be the only way to allow me to access the web from my PC.

Other machines on the network work fine, if I reboot into XP everything works fine.

This is the second time this has happened. The first time after spending hours on the issue I noticed that I was using an updated -through windows update- driver for my networked card (Realtek RTL8101E built in the motherboard), rolling back to the older driver version that came with windows 7 seemed to have solved the issue, apparently not, a couple of days later the same problem is happening again.

Any ideas / pointers to things I could have missed ?

share|improve this question
add comment

1 Answer

I have not seen this exact issue, but I have a laptop with the same controller and I had some weird random issues similar to what you are experiencing.

I went to the Realtek Website and manually updated the driver to the latest version which fixed everything for me.

share|improve this answer
    
doing that right now ... For some reason it did not occur to me that Realtek might have a different driver than the one I got through windows update! :-O –  Pat Jan 27 '10 at 14:27
1  
The new driver seems to be working ... let's see how long it'll last this time :-) Accepted. –  Pat Jan 27 '10 at 16:30
    
Cool! No idea why the stock one seems to have errors, you got off lightly - for me, it caused BSOD on large file copies! –  William Hilsum Jan 27 '10 at 16:31
    
Just happened again now... Disabling the Network adapter and re-enabling it seems to solve it temporarely... so un-accepted but +1 for the suggestion :-) –  Pat Feb 17 '10 at 15:39
    
@Pat It is still the same issue though - try updating to the latest version again! –  William Hilsum Feb 17 '10 at 23:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.