Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At what seems to be at random intervals my secondary drive in my workstation just disappears. The OS is not installed on this drive (it's my "E:" drive). I'm not using RAID.

  • The PC is a Dell Precision T3500 running Windows 2008 R2.
  • It contains a Intel Matrix Storage Controller on the motherboard (v8.5.2.1002). I'm running the windows software for that controller v8.9 (which I guess contains windows drivers - which is why I mention it).
  • The failing drive is a Western Digital WD4000AAJS-0 which is a 400 GB 7200 RPM drive SATA (firmware 12.01C01)

I notice system event log entries that seem to correlate to the times the drive goes away: Source isStor, Event ID 9, Description: The device, \Device\Ide\iaStor0, did not respond within the timeout period.

This drive was working fine for more than a year in another PC and was moved to this machine for about 3 months. However, this problem started only a week ago.

Googling for this problem seems to point at the intel matrix controller. Yet none of the workarounds I've found help. (renaming a registry key, updating the matrix software, switching sata ports)

Any ideas?


Update The drive started to not just disappear but stay visible and deny access to some files on the drive. I ultimately copied what I could to the working main drive and disconnected it. This workstation's primary drive is too small for the work I do so I'll hook up other drive at some point and post the results here. (Why add 12GB of ram for hosting virtual machines but choose 250GB drives so i have no room for VHDs??)

Also I tracked down to the event log that the problem started the same day I installed Remote Desktop Services role (aka terminal services) in attempt to get Aero glass working over remote desktops to this PC (don't ask). I ended up removing that role since it didn't help. I wonder if some type of power management setting was flipped on/off during the add or remove of that server role?

Update 2 After a few years of running this machine with only one drive (the one dell ships) after never really resolving this issue I ended up installing a second drive again. This drive, a 2012 WD Caviar "black" (WD1002FAEX), seems to be running fine with none of these issues. I assume this issues was caused by bugs in the SATA power management of older drives with this controller/windows 2008.

share|improve this question
    
Windows 7 x64 here, also matrix board but not used (ACHI mode). I have a eSata external drive enclosure that disappears after a while. I just want to mention that I can find it again by doing a "Scan for hardware changes" in Device Manager. Reading harrymc's answer, I just tried disabled power management altogether (high perf mode) and I'll see if it helps. –  mtone Jan 27 '10 at 20:51
    
For what it's worth I can never re-find my missing drive - even with scan for new hardware in Window's Device Manager or in Intel's Matrix Storage application. (it takes a reboot) –  Aardvark Jan 29 '10 at 16:41
add comment

3 Answers 3

up vote 1 down vote accepted

The following Intel article seems to address your problem:
Intel Rapid Storage Technology : Possible issues with Windows Vista* and Intel® RAID

Some excerpts from the text:

Description

The following issues may occur on Windows Vista* with a supported Intel® RAID controller hub:

  • Timeout errors reported by iastor or iastor(v) in Microsoft Event Viewer

Cause

Various desktop Serial ATA devices such as hard drives and CD/DVD drives have been reported that do not comply with the Serial ATA Link Power Management (LPM) device specification and display erratic behavior when LPM is enabled.

Solution

Install Intel Matrix Storage Manager version 7.5 or later. These versions workaround this issue by disabling Link Power Management (LPM).

If you are experiencing installation issues, you can also use one of the following additional workarounds:

  • If available, install updated firmware for the device.
  • Attach the device(s) to ports 3-5 on the Intel® 82801HR/HH/HO I/O controller hub (ICH8R) or port 3 on the Intel® 82801GR/GH I/O controller hub (ICH7R)
  • Switch to IDE mode in the system BIOS.
    Note : This change will disable RAID functionality. Contact your BIOS manufacturer for instructions on how to switch to IDE mode.
share|improve this answer
    
I've tried all those options except switching to IDE mode (windows won't boot if I change that - seems I'd have to reinstall my OS). –  Aardvark Jan 27 '10 at 20:29
    
@Aardvark: Switching to IDE will require a reinstall, but "might" get rid of this RAID bug. –  harrymc Jan 27 '10 at 21:43
1  
@Aardvark: According to the article, the problem is probably that your hard disk is not suitable for your configuration. –  harrymc Jan 28 '10 at 6:33
    
What's strange is that this problem seems to be getting progressively worse. I ultimately had copy what I could to the working drive and I disconnected the other. –  Aardvark Jan 29 '10 at 16:23
    
No changes on the firmware, matrix windows software, or windows settings helped. Using a different model drive did workaround this issue. –  Aardvark May 23 '12 at 13:45
add comment

I've had a similar problem and think I've found a solution.

Configuration:

  • Dell M6500 laptop
  • Vista 64-bit Business SP1
  • Intel ICH8M-E/ICH9M-H/PCHM SATA RAID controller
  • Intel Matrix Storage Manager 8.9.4.1004
  • 2 Seagate ST9250410ASG disks
  • Raid 1 configuration

Problem: After running without problems for a week after the purchase, one day the drives started failing more or less arbitrarily. About once a day, the Intel Matrix Storage Console would report one of the drives as failed. After a reboot, the drive would reappear and the controller would successfully rebuild to the failed drive, and return to normal state.

I noticed these events in the Windows event log, correlated to the times a drive disappeared: Source isStor, Event ID 9, Description: "The device, \Device\Ide\iaStor0, did not respond within the timeout period."

Solution: I read this article:

http://www.intel.com/support/chipsets/imsm/sb/cs-025783.htm

but since I was already running a much newer version of the Intel Matrix Storage Manager, this does not solve the problem. However, after reading about the relation to Link Power Management in the article, it struck me that on the exact day that the problem started, I had switched the Windows power plan from the default "Dell" plan to the "High performance" plan.

I compared the advanced settings of the power plans, and noticed that they differ in the option PCI Express | Link State Power Management. The high performance plan has Link State Power Management turned off, while the Dell plan has it to "Moderate power savings" while plugged in, and "Maximum power savings" while on battery.

So, I switched the power plan back to "Dell", and since then (for about a month), I've had no problems and no entries in the event log. I've been running plugged in all the time, so it's the "Moderate power savings" setting that I've been using.

So, the solution seems to be to use a Windows power plan that has PCI Express | Link State Power Management set to "Moderate power savings" (or perhaps "Maximum power savings").

share|improve this answer
add comment

put a small page file on the drive that is getting disconnected--it could be an orphan power management issue and a page file will keep the drive spun up

edit: actually, re-reading your OP, if the drive is showing up in explorer but you can't access some of the data, it sounds like the drive itself is failing. can you reproduce the issue if you attach a different drive to the same port?

also try replacing the SATA cable first since it's cheaper than a new drive

share|improve this answer
    
It SOMETIMES disappears and SOMETIMES stay but doesn't work (files appear corrupted). Rebooting brings everything back - including magically healed "corrupted" files. Good idea with the page file - but I'm a bit worried a bad page file will cause a bluescreen. I'm going to try a new drive at some point. –  Aardvark Feb 3 '10 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.