Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed VLC player, because it works better that other video player on HD videos, but know I have an issue all most of my games (All of those using Bink Video, that means all Unreal Engine games, Call of duty, and more).

When I load the game, I can hear the videos, the audio is working, so I know the videos is loading, but there is no image on the screen!

Once I read that it was a known VLC issue with DivX or something like that, cant remember, does anyone, know a way to fix it?

Thanks in advance

share|improve this question
2  
I have experienced a problem similar to this, without any relation to games (as I don't game on my PC). In my case some specific video encodings are rendered extremely dark, after I installed VLC. I have found a "workaround" to this, in that if I open the video in one instance of a player (e.g. VLC, MPC, whatever), pause it, and then open the video in another instance of the player, the second instance is rendered correctly at proper brightness. You want an answer, of course, but in the meantime a workaround may help you. –  JMD Jan 27 '10 at 18:47
2  
Err... What's the issue? –  Macha Jan 27 '10 at 19:18
    
Thanks!!! Forget the issue, POST UPDATED!!! –  Fladur Jan 27 '10 at 19:35
    
I have experienced a problem similar to this, without any relation to games (as I don't game on my PC). In my case some specific video encodings are rendered extremely dark, after I installed VLC. I have found a "workaround" to this, in that if I open the video in one instance of a player (e.g. VLC, MPC, whatever), pau.... I would like to have that as an answer, as that fixed my problem. –  Fladur Jan 28 '10 at 22:05

2 Answers 2

up vote 0 down vote accepted

VLC's supported video codecs are listed on their website. As you can see, Bink video is not supported. The reason you are getting the audio is that they are probably using a common format for the audio such as MP3, AAC or RAW. You should be able to tell by looking in the Tools->Codec Information menu. You will have to use another tool to convert the videos in order to play them in VLC. Perhaps this other answer can help you convert the videos.

share|improve this answer
2  
I dont want to play videos in VLC, i want to play them in game, like cut scene and so, but theres no audio. –  Fladur Jan 27 '10 at 23:54

I haven't tried these solutions yet, but I believe the issue that you're experiencing is that the "directshow filter" expected by the game is being overridden by the one installed by VLC. See here for a utility developed by Oblivion users to reset your directshow filter list to the default, or try Nirsoft's "InstalledCodec" to browse the list of currently installed codecs and temporarily disable some.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.