Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have annoying problem. My setup is the following: debian Linux, 64 bits, VMWare workstation 7 host, with Windows XP running as guest. From Firefox, or Internet Explorer, I am unable to access few sites, for example nvidia.com, osdir. Basically get connection timed out, on the other hand ping works to those sites. Moreover, Slashdot loads very very slow and sometimes gets horrible text-only version.

everything works fine on Linux host

I suspect it has something to do with routing on Linux, I recall having similar problem long time ago, which was fixed by setting something in /proc.

I tried setting MTU and TCP window size on Windows lower, but did not help

Any idea what is going on?

share|improve this question
    
I've had an exactly this problem with a PPP connection with my provider on Linux, and that was temporarily fixed by setting MTU 2-3 times lower than normal (e.g. 1000, 800 or even 600). Did you tried such low values? –  whitequark Aug 17 '10 at 23:27

2 Answers 2

unknown,

You haven't specified the network connection type from the guest to the host. Your explanation suggested a routing issue on the Linux side. From that I am guessing you are using the DHCP enabled virtual networking segment. My rule of thumb is to use NIC adapter bridging. I don't use the virtual networking segments on VMWare workstation unless I have a good reason. Using the bridging option reduces both complexity and overhead from the virtualization environment. With bridging you can even remove the IPV4 or IPV6 from the Linux OS and the VMWare host will still run without complaint.

Very cool.

My suggestion is to disconnect the Windows XP guest NIC from the virtual network segment and change it to the 'Bridge' or 'Bridging' option.

share|improve this answer

I know that this is probably your not case, but you could try to take a look at the DNS for your guests OSes? I'm using google DNS, that work kinda good: 8.8.8.8 and 8.8.4.4; you can also give a try to OpenDNS i you like: 208.67.222.222 and 208.67.220.220.

Bye

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.