Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running VirtualBox (with XP-Guests and soon W7) on a Win2003-server. Just recently (and with help of a superuser), I was able to see the VM in the network (before I could only connect to the web and see the intranet from the VM, but not see the VM).

Some details:

  • IP of gateway: 192.168.1.1
  • IP of host: 192.168.1.199

On the hosts's LAN-connections, I have a "VirtualBox Host-only network" and in its TCP/IP-settings have assigned the IP 192.168.1.51.

The VM still runs with automatic assignment of an IP and currently uses 192.168.1.5.

I hope this gives all info you may need, please just ask if I left out something...

edit: I see few people viewing the q and not responding. If I'm moving in the wrong direction or am doing something stupid (obvious for anyone but me) - please. add a comment ;)

share|improve this question
    
Have you tried setting the lan device to "NAT" mode? That has cleared up most problems for me in the past. –  Seamus Feb 17 '10 at 8:35
add comment

2 Answers 2

The virtualbox host-only network is a private network between the host and the guests and not available to the outside world.

It should be on a separate network to your real network as my guess is, you are having a routing conflict.

Try setting it to automatic / DHCP, or use an alternate network allocation such as 10.0.0.x on /24 or 255.255.255.0 subnet, with no gateway.

share|improve this answer
    
In the previous question, he asked how to expose the vm to the production network (bridged mode). I think that's the situation he's trying to use now. –  MDMarra Jan 28 '10 at 14:02
    
Thanks Wil, I have set the vb host-only network's IP-config to automatic, but it still takes my server from the network when I launch the vm :( With the little knowledge I have, the routing conflict sounds like a plausible explanation, but how to find the root of that? –  MBaas Jan 28 '10 at 14:33
    
I think it is still a routing conflict, I am not sure what defaults virtualbox uses.... Can you manually disabled the virtualbxo host-only network and just see if everything goes correctly? If it doesn't write in comments as I may be out of ideas, but if it fixes it - I have a theory - can you manually change the host only network to 10.0.0.anything and then see if it changes anything, alternatively, do an ipconfig and paste the results for that card. –  William Hilsum Jan 28 '10 at 14:52
    
Disabling host-nw has not changed anything :( I also tried to assign a 10.0.0-IP without effect... –  MBaas Jan 29 '10 at 15:20
add comment
up vote 0 down vote accepted

Hoooorrray :) The 3.1.4-update somehow just fixed all problems, I'm in (virtual) heaven now :) Thanks for all your help & support, much appreciated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.