Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently whenever I start OS X (10.6.2), mail.app starts up with a "Welcome to Mail" dialog, asking me to create an account by inputting name, email address, and password. If I cancel this dialog, the app just hangs and I have to force quit it.

I do not use the mail.app and I do not want it to start up with OS X. I have checked the login items and it is NOT present in the login items list for my account. I have also ctrl+clicked the doc icon that appears and confirmed there is no option enabled for "Run at Login".

If I go ahead and just spam continue through the dialogs for a new account, I can get through to actually using Mail and accessing preferences. I cannot find a startup option in Mail preferences. After I have completed this, if I now restart, Mail does NOT open automatically. However as soon as I delete the account that I created, it once again goes back to popping up a "Welcome to Mail" dialog every time I startup and login.

As best as I can tell, it seems OS X checks if an account exists in the Mail app, and if it does not, it will always start up a "Welcome to Mail" dialog on login, regardless if the Mail app is set to run via login items, etc.

This is incredibly frustrating given I have no intention of using the Mail app. I realize I can easily leave account info in there (perhaps even disable the account via preferences), but this behavior is ridiculous.

Update:

Further tested this by creating a new account. I confirmed that the dialog will still start up and that mail is not set to start on login; neither via Accounts -> Login Items or right clicking it on the dock and checking for the option there.

share|improve this question
    
is there anything in that startup items list that could start a default mail client? –  yanokwa Jan 28 '10 at 16:15
    
no - I actually have nothing present in the login items list –  mindless.panda Jan 28 '10 at 16:37
4  
Does this happen with other user accounts or just your own? As a test, try creating a new user account as similar to your own as possible and log in with it. Whether or not Mail.app launches narrows down where to look to find the problem. –  Stephen Jennings Jan 30 '10 at 16:03
    
Stephen - great idea, I will try this today –  mindless.panda Jan 30 '10 at 16:26

5 Answers 5

up vote 4 down vote accepted

This is probably related to iCal. I have the same problem and I use iCal in sync with my Google calendar, which is configured to send emails for certain events.

Disabling 'Automatically receive invitations from mail' in iCal preferences does not help.

This post has some more info: http://discussions.apple.com/thread.jspa?threadID=1853470

share|improve this answer
    
You are correct. –  mindless.panda Apr 13 '10 at 18:12
    
Also see this answer, which provides a way to simply stop Mail from opening, period, no matter the cause. –  Nick Wiggill Nov 7 '12 at 9:21

If you're sure you don't need it, you can just delete it or create an archived backup, for future, and delete.

share|improve this answer
    
Delete the mail.app? That won't break OS X? –  mindless.panda Mar 9 '10 at 21:45
1  
OS X is Apple, no? Ergo, it will "just work" once you delete it. –  ta.speot.is Apr 11 '10 at 7:49
    
+1 for deleting the mail.app program. I'm actually going to try this when I get home myself since I never use Mail.app (prefer Thunderbird when I have to use an external mail app). I'll report back my results. –  Matrix Mole Apr 11 '10 at 7:59

I'm experiencing the exact same behavior on 2 of my systems (10.6.2 & 10.5.8)

I think the behavior may be connected to ical Do you use it?

On my leopard system I have never used mail and mainly run it remotely as a server, however I used ical to mirror the my Google calendar from my main system. The message I get from mail on the setup screen has details of my Gmail etc, presumably from ical as I haven't entered this info on mail ever.

On my main system I also get the Gmail detail prefilled. I had assumed this was because I used to use mail and have since went back to Gmail and it had lingering details of previous accounts, however no believe it is linked to ical (which I still use)

Try going to ical preferences (if you use it) going to the advanced tab and disabling 'Automatically receive invitations from mail'

I have just tried this myself and will let you know if this works. Perhaps ical is polling mail for some Gmail info (as the account is shared between Google calendar and Gmail) and is consequently trying to create that account.

Anyway just a thought, it would be interesting if you have a similar ical/Gmail integration.

share|improve this answer
    
You are spot on as my situation is very similar. I will troubleshoot tonight and let you know what I find. –  mindless.panda Mar 29 '10 at 1:20
    
Any joy? It only launches mail for me when an event timer goes off in ical, however i cant see any settings to stop other than the above. –  D0ppelganger Apr 3 '10 at 23:22
    
Yea. This is defintely the cause. Since then I've stopped using iCal (I only set it up to test sync with google calendar). If I wanted to keep using it I would investigate the settings. As it stood it always popped the nag screen as soon as I booted, regardless of event timers going off. Thank you. –  mindless.panda Apr 13 '10 at 18:10

I have never seen Mail launch itself of its own accord on every login. You must have installed something that is doing this.

Download and run this:

http://khiltd.com/software/consultants_canary

Then copy and paste the contents of the resultant Terminal window as code to preserve formatting. You can leave out the top part with your name and serial number and all that jazz.

share|improve this answer
    
I am really thankful for your suggestion and offer to help. While I understand this seem really odd, this is definitely the behavior I am seeing and have seen starting immediately post install of Snow Leopard. For now I am happy with just creating a dummy account and deactiving it, but the minute I delete the account, the Mail dialog asking me to create an account pops up after every login. –  mindless.panda Mar 10 '10 at 1:40
1  
@user26453: One of the things this software seems to report are the LaunchAgents (/Library/LaunchAgents and ~/Library/LaunchAgents). Since you already seem to have ruled out the normal Login Items (Dock/Accounts preference pane), the LaunchAgents one of the next suspects for things automatically launched at each login. Does Mail launch if you login with Shift held down? docs.info.apple.com/article.html?path=Mac/10.6/en/8437.html –  Chris Johnsen Mar 10 '10 at 4:50
    
Great lead - I'll look into this. –  mindless.panda Mar 10 '10 at 5:34

Based on another thread this is the only thing to work for me:

How do I stop Apple Mail from opening because of iCal appointments?

There's really only one way to kill Mail.app (as per my comment on waiwai's answer):

sudo chmod 000 /Applications/Mail.app/Contents/MacOS/Mail

To reverse:

sudo chmod 755 /Applications/Mail.app/Contents/MacOS/Mail
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.