Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend has an Acer Aspire 4810T. The cdrom has stopped working (or never worked after installing windows) and I can't figure out for the life of me why it's not working. When the computer starts up cdrom is fine. Then it dissapears from the device manager and explorer. It vanishes without a trace and in the event log is the following message:

The following boot-start or system-start driver(s) failed to load: cdrom

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
 <System>
  <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" /> 
  <EventID Qualifiers="49152">7026</EventID> 
  <Version>0</Version> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8080000000000000</Keywords> 
  <TimeCreated SystemTime="2010-01-28T20:20:39.690026600Z" /> 
  <EventRecordID>28964</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="572" ThreadID="576" /> 
  <Channel>System</Channel> 
  <Computer>Emmas-Laptop</Computer> 
  <Security /> 
  </System>
 <EventData>
  <Data Name="param1">cdrom</Data> 
 </EventData>
</Event>

Does anyone have any ideas because I am running out of such. I mean it would be nice to know exactly why it stopped working so that I can avoid it in the future.

share|improve this question
    
Hi, any luck? I have the same problem and it would be nice to know if you found the solution –  Grzenio Mar 13 '11 at 11:30
add comment

2 Answers

This event deals with the device driver failing to load when Windows starts, so it would make sense that it works prior. People have displayed various fixes which eliminate the error, you may want to look through them in the EventID article.

share|improve this answer
    
Perhaps he can try verifying if it will keep working when running a LiveCD –  Ivo Flipse Jan 28 '10 at 21:28
    
Great link, will check it out tomorrow! The device works before windows completes loading so yeah it's something to do with that. –  mhenrixon Jan 30 '10 at 20:50
add comment

Does it work in Safe Mode?

Have you tried removing the optical drive from Device Manager (if it's ever visible there, perhaps in safe mode) and let Windows redetect it?

Do you have any software that provides a virtual optical drive (Nero, Alcohol 120%, DaemonTools, etc)? If so, try uninstalling those and see if it affects things.

Have you checked MS's KB314060 article ("Your CD drive or DVD drive is missing or is not recognized by Windows or other programs")?

share|improve this answer
    
I have not checked safe-mode yet. Will do that tomorrow when I have access to the computer. –  mhenrixon Jan 30 '10 at 20:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.