Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If you look at the image below, you'll see that I'm getting the iPhone version of Google on my Mac. If I refresh, it stays the same, but curiously enough, if I visit https://www.google.com (note SSL), it looks fine. If I do a search, it first takes me to the iPhone results, then upon refresh, it displays the normal results.

Things I have tried:

  • Checked Useragent (this may actually be part of the problem... I had switched to iPhone useragent for something and then switched back, but I had visited Google in between)
  • Deleted cookies
  • Deleted com.apple.Safari.plist

picture

share|improve this question
    
What happens if you hit that Classic link down there? –  Nathaniel Jan 28 '10 at 22:40
    
It becomes normal... but when I come back, it's back to mobile. –  waiwai933 Jan 28 '10 at 22:47
    
Does the same thing happen if you visit a different Google, say, google.co.uk ? –  MJeffryes Jan 30 '10 at 22:51
    
No, it seems to be limited to google.com –  waiwai933 Jan 30 '10 at 22:54
    
I put another thing to try in my answer. Maybe it will help? –  Yar Jan 31 '10 at 3:08

3 Answers 3

up vote 2 down vote accepted
+200

Try emptying your cache.

I reproduced your problem by changing my user-agent to "Mobile Safari". Even after changing it back and restarting Safari, it still showed the mobile version.

I tried using "Reset Safari" and just flagging "Delete cookies", but that did not work.

However, when I used "Empty Cache", Google started working properly again.

I did this a few more times just to confirm that it was "Empty Cache" that was fixing the problem. I don't know why this works, though.

share|improve this answer
    
One would think that reset safari already does that! Apparently not... strange. Congrats! +1 –  Yar Feb 1 '10 at 11:21

What does this page say about user-agent and accepted media types?

Your problem seems to be in the headers Safari sends, since the normal page is restored after one visit. I suspect Safari is accepting a wap mime type (text/vnd.wap.wml, application/vnd.wap.xhtml+xml).

share|improve this answer
    
Accepted media types: application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/pn‌​g,*/*;q=0.5 –  waiwai933 Jan 30 '10 at 23:35
    
Same as I have. Oh well. –  Tobu Jan 31 '10 at 10:42

What version of Safari are you using? if changing the user agent back to normal doesn't fix anything, maybe reinstalling Safari would help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.