Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have for years been using VirtualBox under Linux (currently Ubuntu 9.10) to run Windows XP Pro as a guest OS. It worked fine until today, for some reason, the Windows guest stopped resizing to match the size of the VB window. Also, the maximum resolution permitted by Windows is now 800x600. I have upgraded to the latest stable VirtualBox and reinstalled the Guest Additions without changing anything. Any suggestions? I'd rather not revert to the last snapshot if possible because I've installed lots of software since, e.g. Adobe Flex Builder.

EDIT: I tried starting a CentOS virtual machine and while it works fine in text mode, it cannot display in X (black window), indicating that the problem is either in VirtualBox itself or in Xorg. Ubuntu did update Xorg recently.

share|improve this question

closed as too localized by random May 29 '12 at 19:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 1 down vote accepted

Sorry to waste Molly's time. Purging and reinstalling VirtualBox seems to have fixed it. I imagine some setting was wrong, but since I use this VM for work I couldn't leave it unfixed long enough to debug.

share|improve this answer
    
not to worry. you got it fixed, that's what matters :) –  Molly7244 Jan 29 '10 at 11:40

Use the key combination HOST + G to toggle automatic resizing. This is also available through the menu Machine -> Autoresize guest display.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.