Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set the mouse acceleration and sensitivity levels to minimum in System->Preferences->Mouse but with the new mouse I have, even those settings are too fast. Is there a way to further reduce the speed? The resolution of the mouse seems to be much higher than needed. Is there a way to reduce that?. The mouse is an Okano A1020 Laser Mouse. lsusb -v says the following:

    Bus 006 Device 002: ID 12cf:0047  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x12cf 
  idProduct          0x0047 
  bcdDevice           51.04
  iManufacturer           1 MouseCenter
  iProduct                2 LASER Mouse
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Device
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      2 Mouse
      iInterface              0 
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.11
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      46
         Report Descriptors: 
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
Device Status:     0x0000
  (Bus Powered)

EDIT: In the meantime, I tried xset m 0 0, which didn't improve anything either, the mouse stayed at the same speed.

another edit: Thanks for asking, I didn't notice this earlier. The acceleration setting does have an effect, but the sensitivity setting does not. Also, I double checked the company name and model, and it is correct as stated.

share|improve this question
    
Does changing the settings actually affect it? Do you notice the mouse going slower after changing them, or does it not work at all? –  Adriano Varoli Piazza Jul 24 '09 at 14:38
    
I can find neither the company nor the mouse, is the model and make on the mouse really correct? –  Stefan Thyberg Jul 24 '09 at 14:40

5 Answers 5

up vote 10 down vote accepted

http://patrickmylund.com/blog/lowering-gaming-mouse-sensitivity-in-ubuntu-9-10/

share|improve this answer
    
thx, works perfectly. A few months late though ;) –  Kim Sep 30 '10 at 10:17
    
@Tamale - For some reason, my mouse still got a huge acceleration, which is really annoying. :( –  Shiki Dec 19 '11 at 14:47
    
Thanks for this answer. The xinput properties were exactly what I needed to do to slow down my son's optical mouse on Qimo/Ubuntu –  Rob Allen Mar 18 '12 at 15:34
    
Thank you, that works perfectly for my Lenovo Laser Mouse @1600 DPI. –  Aybe Jan 8 '13 at 14:13

Here is a solution related to a Logitech mouse. Simply add the following lines to .profile:

logitech=$(xinput --list --short | grep -m1 "Logitech USB Receiver" | cut -f2 | cut -d= -f2)

xinput --set-prop "$logitech" "Device Accel Constant Deceleration" 4
share|improve this answer
    
you can write $(....) instead of backticks –  Kim May 20 '11 at 10:14
    
@Kim I changed that, way easier to read. –  slhck May 20 '11 at 10:25

This isn't the simplest way to do it (i.e. not a GNOME or KDE preference) but you can tell the X server to use a specific mouse speed for your device. To do this you have to edit /etc/X11/xorg.conf manually and restart X (easiest way is to reboot the machine). The tricky part is identifying your mouse driver in that file. Start by looking for a section called "InputDevice" that matches your mouse driver. On my laptop for instance, where I'm using the mousepad, the section is called "Configured Mouse". You then set options as described in this thread: http://ubuntuforums.org/showthread.php?t=227562. The device in question is a laptop mousepad, and you will have to play with the numbers, but some variation of it should work.

Option "MinSpeed" "0.45"
Option "MaxSpeed" "0.75"
Option "AccelFactor" "0.020"
share|improve this answer
    
Thanks for your answer, but I'm afraid it will only work for older versions of ubuntu. The section in my xorg.conf that used to be used to configure the mouse is now commented out with the not so helpful comment "#commented out by update-manager, HAL is now used". I heard you have to edit/create config files for HAL now, but I can't find a tutorial on that anywhere, at least not for the specific problem I have. All this for a stupid mouse! God help me... –  Kim Jul 25 '09 at 5:41
    
Oof. That is frustrating. I don't know of a good HAL reference to recommend either. (HAL, like GConf, and DBus really makes a modern Linux system work. I strongly agree with you that in wishing they were less opaque though.) –  quark Jul 25 '09 at 19:18

It is likely that you have the DPI settings wrong. Acceleration settings and the like won't fix this.

share|improve this answer
    
i guessed so...so how dou you fix that? –  Kim Nov 3 '09 at 5:10
    
I've had the same problem with DPI and haven't figured it out yet. Sorry. –  Christian Oudard Jan 24 '10 at 16:38

What kind of mouse are you using? My Logitech G7 has speed settings built into the mouse. If you have a similar mouse, it might be set to the maximum speed. I know when I have it set to the max, it is very fast.

I can't imagine the lowest speed in ubuntu would still be too fast...

share|improve this answer
    
he says it's a "Okano A1020 Laser Mouse" –  warren Jul 24 '09 at 13:54
    
It doesn't have any speed settings built in. –  Kim Jul 24 '09 at 14:32

protected by Community Jul 30 '11 at 10:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.