Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading my power supply, I get the following error message when trying to boot into Windows 7.


My Windows 7 installation is on a SATA hard drive.

I'm able to fix this problem if I hook up my IDE hard drive, then it boots the SATA hard drive fine.

I don't like this solution though because then that means my IDE hard drive is drawing power even though it isn't being used.

Why would a newer power supply need the IDE hard drive hooked up just to boot into the SATA hard drive? There are no boot files on the IDE hard drive; it is completely empty. My old power supply did not need it hooked up in order to boot the SATA hard drive.

share|improve this question

Try booting to the recovery console with your install CD (which is a recovery disk), without the IDE disk connected (thanks Neal), and doing:

bootrec /fixmbr
bootrec /FixBoot

This will restore your master boot record and boot loader.

You will, of course, want the SATA drive set in the BIOS as a (probably the primary) boot device.

share|improve this answer
Do this without the IDE connected. Your problem is that the mbr code is installed only on the IDE drive, and not on the SATA drive. – Neal Jan 29 '10 at 8:37

Try going into the BIOS and changing the boot order of your individual hard disks vs. CD-ROM drives, etc. It's possible that the boot order reset itself while you were replacing your power supply.

share|improve this answer
Already tried that. Boot order doesn't have any effect. – Phenom Jan 29 '10 at 6:49
It sounds a lot like a broken MBR problem. I had this same error with Windows 7 as well a while back. My computer would not boot without the Windows 7 disk in the CD-ROM drive. I made sure the hard drive was connected to the SATA 0 port, that the BIOS recognized the hard disk and it was set as the first boot device, then used the 'repair' option on the Windows 7 CD to fix the boot loader. That did it for me. In hindsight, I'm pretty sure the last step was the critical one that fixed the problem. – curious Jan 29 '10 at 6:58

Look at your motherboard's manufacturers website for a bios-update. Normally there shouldn't be a problem, if you don't have boot from ide-drive activated in your bios-settings. Also I remember that you had to remove floppy-disks from floppy-drives when they were before the harddrive in the bios-settings....

share|improve this answer
Update the bios may fix this problem, you'd better consult your hard disk manufacture before you do that. – John Jan 29 '10 at 6:37
I don't really think this has anything to do with the harddrive. If it is able to boot windows seven from it, then it works. – BasisBit Jan 29 '10 at 7:13

My PC also refused to boot without the installation disk in place, after a re-install of Windows 7 that renamed my old Windows folder to "windows.old".

I was about to go for the Repair operation but decided to check the BIOS (for boot priority) first and discovered that the reinstall had somehow disabled my HDD in the BIOS. Because of this, the BIOS was saying that there was no drive present on the PC (this would be enabled once the install disk started to boot).

Anyway, I enabled my HDD and the problem was solved.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .