Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Ubuntu display resolution is 800x600. I want to change it to 1024x768. Someone told me to edit xorg.conf to achieve this, but I can't save the file. How can I edit the file ?

share|improve this question

4 Answers 4

You need to use sudo in order to edit xorg.conf. In a terminal you can run sudo gedit /etc/X11/xorg.conf. Or you can use the system configuration tools in the gnome menus, which should prompt you for your password, and allow you to configure your screen without having to edit the file manually.

share|improve this answer
    
i tried from configuer the screen but ther is 800x600 but i want 1024x768 therfore i want to edit it but its rejected to save .... –  saleemrehman Jan 29 '10 at 7:02
    
@saleem, did you actually try with sudo as Justin suggested? –  Jonik Jan 29 '10 at 7:37
    
no how can i try this sudo ? plz tell me complete solution ... –  saleemrehman Jan 31 '10 at 7:45
    
sudo is a command you run from the terminal - open a terminal and type in "sudo gedit /etc/X11/xorg.conf", and press enter to run it. But if configuration is failing by the normal methods, editing the file by hand may not be much help. –  Justin Smith Jan 31 '10 at 15:35

I had this problem and I was told xorg.conf is no longer in use.I followed guidance from ubuntu forums and solved the limited resolution in ubuntu 9.10. using xrandr.You may see the following. http://ubuntuforums.org/showthread.php?p=8595940

share|improve this answer

normally you should be able to change the display-resolution by doint this: Menu System; settings; display and check the resolution-dropdownbox most time when this fails, you don't have the right graphic-card driver in your system

share|improve this answer
    
i have nvidia geforce fx5200 and i intall it but when i go to display it says that unknown hardeware/.. –  saleemrehman Jan 29 '10 at 7:00
    
ok, please also edit your question and add what you answered me as additional information. In Ubuntu, Go to System - Systemconfiguration or administration (depends on your installed language) - Hardware-drivers. there it will search for drivers and it should ask you, if you want to install the propietary driver for your nvidea-card, do this and after the install restart. then open the displaysettings-selection window (see my previous post) and check what it says now. –  BasisBit Jan 29 '10 at 7:05
    
as u say i tried that method too but in hardware-drivers i find 2 drivers both are nvidia . i activat both but seperate time but its still same ... –  saleemrehman Jan 29 '10 at 7:09
    
The Nvidea-Driver with version 173 or never should work. but perhaps entering this in a console could help, too: sudo nvidia-xconfig –  BasisBit Jan 29 '10 at 7:20
    
if it doesn't help, try my next answer I made... –  BasisBit Jan 29 '10 at 7:22

You can completely reconfigure X by doing this:

first change to console by gressing Ctrl/Strg + Alt + F1 and login there.

execute "sudo /etc/init.d/gdm stop" (or kdm for KDE) then "sudo dpkg-reconfigure xserver-xorg" then enter this to start your gnome or kde desktop again: "sudo /etc/init.d/gdm start" (or kdm for KDE)

share|improve this answer
    
how to configuer its –  saleemrehman Jan 29 '10 at 7:33
    
? "how to configure its ???" normally if you enter these things, it will to everything automatically and reset the x-org configuration. If it still doesn't work, enter sudo nano /etc/X11/xorg.conf and change the values in the monitor-section to something like this: Section "Monitor" ....Identifier "CM752ET" ....HorizSync 31-101 ....VertRefresh 60-160 EndSection –  BasisBit Jan 29 '10 at 7:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.