Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

usually when I boot into Ubuntu 9.10 nowadays, I get a terminal only (no desktop, etc) asking me to login. Once I do, I still only have terminal access. It takes somewhere between 3 - 10 restarts to get it to boot up normally. If anyone has an idea of what's going on, I'd appreciate any help.

share|improve this question

migrated from serverfault.com Jan 29 '10 at 7:22

This question came from our site for professional system and network administrators.

    
One of the times it boots into terminal, try running -sudo gdm start- to see if it loads the desktop (sounds like the manager mayh not be starting). If not, give us the error. –  Zurahn Mar 14 '10 at 0:17

4 Answers 4

up vote 1 down vote accepted

You need to have a look at your log files to figure out why it's not starting. Start by looking in /var/log/Xorg.0.log when it doesn't work. If you just look in the /var/log directory you'll see a number of files that follow the pattern Xorg.#.log. Each time Xorg starts it bumps all the number in these files so 0 is the most recent followed by 1 etc. So if you look back at some of these files you probably already have one or two files showing the problem. Look for lines that start with (EE) as these indicate an error. Then update your question with either the entire file or the lines that start with (EE) which indicates an error.

But this question does belong on superuser.

share|improve this answer

This may be best on superuser.com.

None the less, if you type startx after you log in can you get to a GUI mode? or does it crash. If it crashes what is the error message.

share|improve this answer

Is your screen flickering a few times before displaying the console? Maybe your graphics are misconfigured. If so, you can boot in recovery mode to repair that.

share|improve this answer

It seems like it is an error with Xorg config file? Have you checked inittab to make sure default runlevel is 3?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.