Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the latest version of Cygwin to try to cd into a network drive on Windows XP Pro Service Pack 3. The path in Windows Explorer to this directory is something like:

\\myserver\photos\original

I tried mounting it to a drive letter ('X') in Explorer, which worked just fine, but then when I ran the command:

ls /cygdrive/x/

It just froze there and hung. Any ideas how I can go into this directory and at least taking a listing of the files in there?

share|improve this question

3 Answers 3

To add to quack's answer: You can access the network drive also via

ls //myserver/photos

However, on my nachine (Vista) it works only after at first pointing the explorer there (\myserver\photos) and entering my username and password.

In the Cygwin docs they lose a short word about this.

share|improve this answer
    
Awesome. This works without mounting the drive in windows as a letter. –  Rubistro Jun 3 '13 at 5:56

You're doing it correctly -- this process works on my setup. The /cygdrive/X notation should work for any drive that Windows has mounted and given a drive letter.

  • Can you browse this network share in Explorer? (Your question doesn't state so explicitly, so double-check.)

  • You can try a standard Windows cmd shell (not Cygwin) -- Windows' builtin pushd will auto-mount the share to a temporary drive.

    C:> pushd \\myserver\photos\original
    
    
    Z:\original>
    

If neither of those work, you've got another problem. (Is the computer with the network share up?)

If those work but Cygwin still can't view /cygdrive/X (or /cygdrive/z after your Windows pushd test), I'd try rebooting your workstation. If the problem persists after a reboot, you may have a broken Cygwin installation; I honestly can't think of any other reasons why it wouldn't work.

share|improve this answer
    
Thanks very much for your help! I can browse it in Explorer, actually, and it was definitely up and running. I just tried the pushd command and that worked, but not in cygwin. It seems that I can't list any files in any network drive. Is there a tool I need to download from setup.exe? –  daveslab Feb 2 '10 at 13:47
    
i can't think of anything in particular; this functionality should just work. i mean, Cygwin is just using regular filesystem access calls, nothing special, so it should be able to list directories and read files on any mounted filesystem. if i were you i'd try uninstalling Cygwin then reinstalling. if you have an old version, consider reinstalling the latest version (v1.7.x of the cygwin.dll). –  quack quixote Feb 2 '10 at 20:50
    
The mounted share is hidden on my setup if mounted after the start of Cygwin. It is shown if I restart Cygwin afterwards. –  tricasse May 11 at 9:48

Stumbled here with the same problem. I know this is an old post but hope it will help others just in case. I had no luck with the suggested solutions. However this worked for me: cd //remotehost/d$ if the the remote host is a Windows machine. The dollar sign does the trick.

share|improve this answer
    
The d$ may get you into the root of the D: drive on that machine, if it's not disallowed. What the OP is looking for is how to get into a specific share on the box. –  Taegost Jul 11 '13 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.