Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my office I have an HP workstation with two dual port graphics cards in it. I then have three monitors connected to these 3x1280x1024) which is my general "at work" setting.

At home I have an HP nc4400 laptop with a docking station, this has a second monitor connected to it and provides dual screen. 1024x768 + 1280x1024.

Both are running Windows 7 Professional.

When I work from home I usually remote desktop to my work pc and run fullscreen on my second monitor on my laptop, keeping other stuff like email on my laptop screen.

If I tick the "Use all my monitors for the remote session" when connecting to my desktop I still only get the one screen/full screen system. Is there any way of getting it to work?

share|improve this question
up vote 5 down vote accepted

It looks like either the RDP client or host has to be running Windows 7 Ultimate or Enterprise. See this Technet answer.

Makes no sense why Win7 Pro is hobbled in some very annoying ways and Enterprise is not. Same thing happened when I wanted to enable Aero over RDP for Windows 7 Pro. Why, Microsoft? Why?

share|improve this answer
1  
On further reading, you can connect to a multi monitor session using Win7 professional as the Client, however, the host/server machine has to be Win7 Ultimate/Enterprise or Server 2008 R2. Madness!! – Robin Day Jan 29 '10 at 18:56
    
Good point. Answer updated. – Matias Nino Jan 29 '10 at 23:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .