Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem:

The desktop and documents folder appear with normal icons.

Attempted Solutions:

  • Restoring desktop.ini
  • Clearing the icon cache
  • Rebooting
  • Restoring the documents icon to default (via Control Panel)
share|improve this question

4 Answers 4

The answer is to assign the read-only attribute to the folder.

eg. attrib +r %userprofile%\Desktop

share|improve this answer
up vote 0 down vote accepted

I wish I could mark one of the answers as "accepted" but reality proved to be even stranger.

Shortly after I asked this question, my laptop was stolen. Consequently, in the interest of increasing my acceptance rate, my 'official accepted answer' is:

Buy a new laptop.

:)

share|improve this answer

Check this page out: "Shell folders are displayed with the standard folder icon in Windows Vista" - it sounds like what you're running into.

Blurb from page:

Symptom:

When you open Windows Explorer, the shell folders such as Documents and Pictures may be displayed with a standard folder icon rather than the special folder icons.

Resolution:

This behavior can occur when the desktop.ini file in the shell folder is missing or incorrect, or it has no attributes set. The default contents of the desktop.ini file for various shell folders in Windows Vista are given below. In each shell folder that's missing the special icon, create a file named desktop.ini and paste the content corresponding to the shell folder.

It then goes on to give you code for the Shell folders' specific desktop.ini settings.

Documents
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
IconResource=%SystemRoot%\system32\imageres.dll,-112
IconFile=%SystemRoot%\system32\shell32.dll
IconIndex=-235

Desktop
[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183
share|improve this answer
    
Unfortunately, this does not solve the problem. –  Zian Choy Feb 2 '10 at 16:13

Here is another way to restore your shell folder default icon in Vista - you may want to backup your information first:

  1. Go to the folder you want to restore. For example, main music or picture folder.
  2. Hightlight the folder.
  3. Single right click
  4. Click properties.
  5. Click customize.
  6. Click choose file.
  7. Go to organize and click.
  8. Repeat steps 4 and 5.
  9. In folder icons click Change Icon.
  10. Click restore default and click OK if you have to, then close all open windows.
  11. Restart your computer. (I didn't restart, I just reopened my main user folder and refreshed the window about 3 times)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.