Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 Home Premium on a new laptop and I'm having one of the most annoying issues with the RDP client (mstsc.exe). If I restore the full screen RDP window, I lose the ability to go back to full screen. The only way I can get it back is by running a new instance of mstsc, setting the option back to full screen, and connecting again.

I don't have this problem on any other machine (granted, this is the only copy of Home Premium I have). Is this a known issue? Is there a patch/fix? It's pretty obnoxious, I'm having to train myself to not use the restore button and only minimize it (which limits uses).

share|improve this question

3 Answers 3

up vote 15 down vote accepted

That's weird, it works fine for me here (Windows 7 Ult. 32-bit).

Ctrl+Alt+Pause should toggle the RDP client in and out of full-screen as well. Does that work for you?

It's also possible for the server-side to have a maximum allowable resolution set. Although I would expect that wouldn't allow the full-screen in the first place, it may be worth looking into.

Perhaps test with another RDP server, if available?

share|improve this answer
2  
CTRL+ALT+PAUSE WORKS! Well, technically CTRL+ALT+FN+PAUSE, which kind of sucks, but at least it works. And yea,that's why I say it's annoying. It's fine at work on Ultimate. It's fine on my desktop on Professional. Just doesn't behave well on my laptop using Home Premium. And it does behave the same when connecting to different servers. If it matters, the laptop is the only machine that has a widescreen resolution (1366x768). Either way, thanks! –  Langdon Jan 30 '10 at 18:43
    
Glad it works. :) Just for info's sake: I tested on my widescreen (1920x1080) originally, so I just bumped it down to 1360x768 and it worked properly there as well. So still weird on yours. ;) –  Ƭᴇcʜιᴇ007 Jan 30 '10 at 18:52
2  
Is it possible to do this without a pause button? –  detly May 9 '12 at 1:38

As others noted, I was able to work around this by changing my resolution from 1366x768 to 1360x768 (I was surprised to find this option in the screen resolution options). Now, I'm able to start fullscreen, restore to windowed, and maximize back to fullscreen. On a Dell laptop running Windows 7 Home Premium x64 with ATI Mobility Radeon HD 3670.

share|improve this answer
    
+1 - worked for me too on a dell studio xps, has been bugging me for months but could never be bothered to fix it :D –  Mark Robinson Jun 6 '10 at 13:01

Here are the steps you should follow:

  • Start "Remote Desktop Connection".
  • Click on "Options".
  • Click on the "Display" tab.
  • On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
  • By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".
share|improve this answer
1  
I just helped you out with the formatting @dogfight, Markdown can take some getting used to :) –  Ivo Flipse Jan 17 '11 at 19:15
1  
Your answer nothing to do re-maximizing a restored remote desktop window as the original question described. –  Langdon Jan 18 '11 at 4:42
    
This worked for me. In the "Display configuration" you can drag the slider all of the way to the right and it will say "Full Screen". –  Dan H Oct 9 '12 at 14:12

protected by Ivo Flipse Jan 17 '11 at 19:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.