Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got rid of pulseaudio because it breaks in so many different situations.

I've switched to Alsa, and all of my sound is working except in mpd. It seems like I have to set audio_output in /etc/mpd.conf. Here is my config file:

audio_output {
    type "alsa"
    driver "pcm"
    name "whatever"
}

When I start mpd, this is what happens:

$ sudo mpd --no-daemon --stdout --verbose
playlist: play 1:"Party Playlist/01 Block Rockin' Beats.mp3"
decoder: audio_format=44100:24:2, seekable=true
alsa: default period_time = buffer_time/4 = 371519/4 = 92879
alsa: buffer_size=16384 period_size=4096
output: opened plugin=alsa name="My MPD Alsa Output" audio_format=44100:24:2
playlist: queue song 2:"Party Playlist/01 Umbrella [Feat. Jay-Z].mp3"
output: closed plugin=alsa name="My MPD Alsa Output"
^Clisten: listen_global_finish called
db_finish took 0.000000 seconds

And I hear the song play for less than a second before the audio_output driver is closed. There really aren't any error messages printed explaining why it's not working.

I've also tried "oss", "esd" and "ao" for the audio_output type, and none of them work.

Does anyone have any idea how to configure mpd for Alsa?

share|improve this question
up vote 2 down vote accepted

Try to turn on driver autoselection:

audio_output {
    type "alsa"
    name "ALSA output"
}

should be enough.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .