Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to access the internet in Linux(Fedora 8).I can access it only in Windows XP.What is the solution for this problem?What changes should I be making to the default settings of the internet on Windows?

share|improve this question
    
This question is far too vague - we'll need more information. –  Phoshi Jan 30 '10 at 15:23
    
The solution for this problem is to use Windows XP. –  geek Jan 30 '10 at 15:54
    
Heck, is this dual-booting on the same computer? If so, what's the computer like? At least at one time, some computers had what was called Winmodems, which were electronic devices that relied on Windows software to become modems. –  David Thornley Jan 30 '10 at 15:56
    
Please describe your setup in detail, especially the connection to the internet. –  starblue Jan 30 '10 at 16:16
    
are you dual-booting, so the system is only running windows or linux? or are you running linux as a virtual guest machine on a windows host? –  quack quixote Jan 31 '10 at 5:39
show 1 more comment

4 Answers

Assuming the two systems are installed side-by-side, you don't need to modify anything in Windows for internet connectivity from Fedora. If your router/modem is configured to provide DHCP leases to clients, you can run the dhclient command on your interface, which can be found from the command ifconfig -a. If you are using static addressing, run the command ipconfig /all on Windows, copy the information down pertaining to the adapter that is connected to the internet (IP address, subnet mask, default gateway, DNS servers...), and apply it statically in Fedora.

share|improve this answer
add comment

Are you connecting via Wireless or Ethernet? What is the output of ifconfig ? If you're connecting via ethernet, try

# ifconfig eth0 192.168.1.66
# route add default gw 192.168.1.1
# echo 'nameserver 192.168.1.1' > /etc/resolv.conf

If there's no eth0, be sure your ethernet drivers are installed or wireless if you're not using any cables.

share|improve this answer
    
Sorry, obviously above you would change 192.168.1.66 to your LAN IP, and 192.168.1.1 to your gateway address –  user26528 Jan 31 '10 at 7:47
add comment

You need to provide more information. Are you using dial-up or broadband, wired or wireless etc? Then you ask "What changes should I be making to the default settings of the internet on Windows?" which doesn't seem to make sense because you stated that the internet was working in Windows.

share|improve this answer
add comment

There are many possible reasons; to try to help you we need more information...

By the way, is there any particular reason that you are trying Fedora 8? The current version is Fedora 12, and using that might sort everything out for you if the problem is something like missing drivers.

Can you tell us how Windows XP connects to the internet, eg wireless network, wired network, ADSL modem, and what sort of connection into the computer it is, eg network cable, USB, telephone.

Can you tell us the result of running the command ipconfig /all at a command prompt in XP (Start -> Accessories -> Command prompt)? Cut and paste the text from the command prompt window.

Can you tell us the result of running the command 'ifconfig -a` at a terminal window in Fedora?

These commands both list the network interfaces on the computer and should give similar-ish resullts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.