Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an iPhone 3G, about a year old, recently upgraded to iPhone OS 3.0. It is not hacked, jailbroken or anything, but I had Telia (who sold it to me) unlock it, so now I use a different operator.

Anyway, I've started to see missing apps. I have WordBook, a dictionary app, installed on my iPhone. It appears in iTunes, and when I go check the list of apps to be synced from iTunes, it is there too. But it is not on my iPhone. The icons appear on none of the home screens, not even after a home screen reset, nor does it show up when I use the new search function on the iPhone.

I'm pretty sure it disappeared after I updated it to it's latest version. And the problem seems to be spreading. I bought the Pingdom iPhone app today in iTunes, and although it is on the sync list, it does not appear on the iPhone after multiple syncs.

I have tried resetting the iPhone's software and restoring from backup, but that did not help either. Does anyone have a possible solution for this?

share|improve this question

5 Answers 5

up vote 1 down vote accepted

This sounds like a known issue with the 3.0 OS, here is a site with instructions to do a full reset and/or reset the home screen layout: http://www.hightechdad.com/2009/06/22/restore-missing-iphone-applications-after-3-0-firmware-upgrade/

Hopefully that is what you need.

share|improve this answer

You can try removing and reinstalling the missing application.

Delete the missing application from the Applications window in iTunes, resync your iPhone, and install the application again.

When you install the app again try using the App Store on the phone. You may have better luck with that.

share|improve this answer

Wen you say it appears in the sync list, is it one of the applications set to sync with the phone?

If you click on the phone in iTunes, then the applications tab at the top. The items you want on the phone have to be ticked.

Otherwise, as others have said, it's a reset required. Back up your phone. The, go into Settings > General and scroll all the way to the bottom and. Click the “Reset” button. Once you are in the Reset screen click: “Reset All Settings“.

Finally, restore the backup and re-sync.

share|improve this answer

unlocked = jailbroken (most of the time)

Have you used the cydia app Catergory? It happened to me when I tried to put apps in folders, somehow it lost/hide some apps.

Btw, if there is Cydia in your phone, try to launch it and let it update the MobileSubstrate.

share|improve this answer
2  
No, Unlocked=Network Locked (you can only use it on the Network Provider that supplied the phone) Jail-broken=Being able to install Applications from sources other than the Apple App Store/iTunes –  Matt 'Trouble' Esse Sep 29 '09 at 23:16

I had a similar problem: checked apps were not syncing. In the Sidebar, under the Library grouping I clicked Applications and it showed all of my apps but most of them had exclamation marks next to them. Double-clicking the app icon brought up a dialog saying that the app was missing. When I went to look for it on my hard drive...it was gone. All of the apps I had downloaded had vanished. A Terminal search turned up nothing. I've no idea how to proceed other than redownloading all of my apps. And who knows how I'll get Apple to give me all the apps I paid for. I guess I'll wait until I can get a Genius Bar appointment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.