Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im currently using the Microsoft 8000 keyboard on Windows 7 and before installing Microsoft's Keyboard application, it was opening Zune and playing music with the play button. After installation, it is now opening Windows Media Player rather than Zune.

If I have Zune open and press play, it will open WMP and upon pressing it again, will kick off the play command in Zune. I've checked the default programs in the control panel and have set Zune as default for all available but that hasn't changed anything.

Has anyone run into this before? I'm a bit stumped as googling does not produce any relevant results.

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

This is a Bug and its not just you

I sent a bug to microsoft and have not heard back from them on this yet...(a year later) I also will point out that if you have both wmp and zune open and something playing on one and something paused on another...(giggle) they will toggle playing state...

share|improve this answer
add comment

It looks like Windows 7 and Microsoft keyboards prefer WMP control if there is a playlist loaded otherwise it will allow you to control Zune without an issue.

Here is how I got it to work:

  1. Open Zune
  2. Open WMP
  3. Make sure the WMP playlist is clear
  4. You can minimize WMP or leave it up as long as the playlist is clear
  5. Now you can completely control the zune even when it is not in focus

It seems that the two keys are having WMP open and the playlist clear, which is weird because I used the same keyboard on XP Professional and Vista Ultimate but didn't experience this issue. I think the WMP integration with Windows 7 is much tighter than previous versions of Windows.

share|improve this answer
add comment

have installed the Microsoft software for the keyboard usually you need to set the preferred action for your buttons especially if different from the standard profile actions i have to this with my Logitech mouse to change the scroll wheel rocker action from scrolling to back / forward

share|improve this answer
    
Yea, I know.. but the action is set to "Play / Pause - Plays and pauses media track." It's just trying to play the media track in the wrong location –  Chance Jan 31 '10 at 18:45
add comment

Make sure you're setting Zune as the default player in the "Set program access and computer defaults" dialog.

share|improve this answer
add comment

After trying all the file association fixes and registry hacks listed here and scattered across the internets I finally discovered that uninstalling IntelliType Pro 7.1 and reverting back to IntelliType Pro 7.0 fixed the issue.

I don'tneed WMP "lurking" in the background for Zune to respond to keyboard controls anymore.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.