Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a small PHP system I created for myself. This system contains a few .doc and .docx file documents. I want to be able to open them directly from the browser without downloading them.

I created a link: <a href="file:///c:/mysite/myfile.docx">myfile</a>. But Firefox does not open the link. href="http://localhost/myfile.docx" works fine - it offers me to download the file.

Any ideas on how I can do it? Do I need to change something in the Firefox options or security settings?

share|improve this question
up vote 3 down vote accepted

Both Firefox and IE8 support the File URI scheme.

Here are some examples valid for Windows systems, referring to the same file c:\WINDOWS\clock.avi

file://localhost/c|/WINDOWS/clock.avi
file:///c|/WINDOWS/clock.avi
file://localhost/c:/WINDOWS/clock.avi
file:///c:/WINDOWS/clock.avi

While the last is the most obvious and human-readable, the first one is the most complete and correct one.

Apparently (from the same url):

Mozilla browsers refuse to follow file URLs on a page that it has fetched with the HTTP protocol.

but:

Mozilla browsers can be configured to override this security restriction as detailed in Mozillazine's "Links to Local Pages Don't Work".

share|improve this answer
    
Thanks a lot! Although the file:/// URI schema did not worked in IE8 and Firefox, i used the extension in the link you gave and it solved the problem. – Aviv Feb 1 '10 at 13:59

Although the solution indicated in Links to Local Pages Don't Work was buggy for a while, it has been fixed.

For instance if the page with file://... links is served on localhost on port 49154, one solution is to

  • exit firefox
  • edit prefs.js, adding the lines

    user_pref("capability.policy.policynames", "localfilelinks"); user_pref("capability.policy.localfilelinks.sites", "https://localhost:49154"); user_pref("capability.policy.localfilelinks.checkloaduri.enabled", "allAccess");

    and possibly for https protocol:

    user_pref("capability.policy.trustable.sites", "https://localhost:49154");

  • restart firefox

File links should now be opened upon left click

(tested with firefox 45 under kde, for a personal weblog called elog)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.