Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to mount any dvd on my HP 6735s laptop running Gentoo (with combined stable (+) and testing (~) ebuilds). Here's everything that I can come up with:

$uname -a
Linux aiur 2.6.32.6-aiur-r5 #6 SMP Thu Jan 28 17:02:59 CET 2010 x86_64 AMD Turion(tm)X2 Dual Core Mobile RM-70 AuthenticAMD GNU/Linux

NOTE: -aiur-r5 is my custom kernel name. I am having this problem with all the kernels since 2.6.31. I use the vanilla kernels from www.kernel.org and compile them with some custom settings using menuconfig.

$ ls -l /dev/{cd,dvd,scd,sr}*
lrwxrwxrwx 1 root root      3 Jan 28 17:37 /dev/cdrom -> sr0
lrwxrwxrwx 1 root root      3 Jan 28 17:37 /dev/cdrw -> sr0
lrwxrwxrwx 1 root root      3 Jan 28 17:37 /dev/dvd -> sr0
lrwxrwxrwx 1 root root      3 Jan 28 17:37 /dev/dvdrw -> sr0
lrwxrwxrwx 1 root root      3 Jan 28 17:37 /dev/scd0 -> sr0
brw-rw---- 1 root cdrom 11, 0 Jan 28 17:37 /dev/sr0

$ grep aatiis /etc/group
disk::6:root,adm,haldaemon,aatiis
audio::18:aatiis
cdrom::19:haldaemon,aatiis
dialout::20:root,aatiis
video::27:root,aatiis
cdrw::80:haldaemon,aatiis
usb::85:haldaemon,aatiis
aatiis:x:1000:
vboxusers:x:1006:aatiis
wireshark:x:1010:aatiis
games:x:35:aatiis

$ dmesg | grep -i dvd
ata2.00: ATAPI: HL-DT-ST DVDRAM GT20L, DC03, max UDMA/100
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GT20L     DC03 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray

$ lsmod | grep udf

NOTE: No UDF module. I compiled it into the kernel this time; however, I was having the same problem when I compiled as a module...

$ lsmod | grep dvd
pktcdvd                20840  0

I guess I need the pktcdvd module for writing DVD's?

$ sudo mount /dev/dvd /media/cdrom
mount: /dev/sr0: unknown device
$ sudo mount -t udf /dev/dvd /media/cdrom
mount: no medium found on /dev/sr0
$ sudo mount -o ro -t udf /dev/dvd /media/cdrom
mount: no medium found on /dev/sr0
$ sudo mount -t iso9660 /dev/dvd /media/cdrom
mount: no medium found on /dev/sr0

Of course, the DVDs are working on other computers. They are not CSS-encrypted. Some of them were burnt by this same dvd burner when I had Debian. Also, DVD burning is not working either. It doesn't even recognizes a blank DVD when I insert it (I like to use the new K3B alpha, but brasero and the other burner tools don't work either). Anyone having this problem? I'm reading forums for a couple of days now as I really need to burn some DVDs. What should I try to do? Any help or suggestion is welcome.

EDIT:

$ sudo rc-update -s
           acpid | boot
       alsasound |      default
             atd | boot
        bootmisc | boot
         checkfs | boot
       checkroot | boot
           clock | boot
     consolefont | boot
            dbus |      default
           fcron | boot
            hald |      default
        hostname | boot
         keymaps | boot
           local |      default nonetwork
      localmount | boot
         modules | boot
           mysql |      default
          net.lo | boot
            ntpd |      default
  postgresql-8.4 |      default
       rmnologin | boot
            sshd |      default
       syslog-ng | boot
  udev-postmount |      default
         urandom | boot
             xdm |      default

So, I have udev-postmount here.

$ dmesg | grep udev
udev: starting version 150
udev: starting version 151

I might have updated it with a recent emerge --update --newuse --deep world --ask, so I guest that's why I have two versions of it?

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# (some more comments here, I omitted them for clarity)

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

/dev/sda1               /               ext3            noatime         0 1
/dev/sda5               none            swap            sw              0 0
/dev/sda6               /mnt/data       ext4            user,rw,exec    0 2

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#  use almost no memory if not populated with files)
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec     0 0

Note that /dev/sda1 (my root partition) is also ext4, but I use the ext3 driver right now.

$ dmesg | grep sr
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
sr 1:0:0:0: Attached scsi CD-ROM sr0
sr 1:0:0:0: Attached scsi generic sg1 type 5

Thanks for the responses. Any more info I can provide?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I am having this problem with all the kernels since 2.6.31

does that mean that if you boot 2.6.30 the drive works, or that you've had this problem since 2.6.31 came out.

it sounds like your drive could just be dead. When you try to mount a disk, does the drive even spin up?

share|improve this answer
    
Oops, sorry to not update this question. It started with the dvds not getting mounted, and ended with a completely broken drive. I'm unable to boot from my optical drive and also I can't use them on other OSes (tried BackTrack 4 final). So it turns out to be a device problem after all... –  Attila O. Mar 7 '10 at 12:50

When you do the mount command is there any message after it in dmesg?

share|improve this answer
    
Nope, dmesg stays intact. –  Attila O. Feb 1 '10 at 19:01

I'm surprised to see sr0 instead of plain /dev/dvd .. In your /etc/rc.conf (or /etc/conf.d/rc, I can never remember), are you doing "use_device_tarball = yes" ? Are you using UDEV all the way? Please show us your fstab.

share|improve this answer
    
In my /etc/conf.d/rc I have RC_DEVICE_TARBALL="no". I use udev. I'm updating my question to append the additional info (fstab and init scripts). –  Attila O. Feb 1 '10 at 19:05
    
Did you compile the proper options in the kernel (SCSI Generic, CD DRIVE support) ? –  Trevoke Feb 3 '10 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.