Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

using vim via ssh on a machine with an x server running throws an X error. Specifically:

>vim
BadWindow (invalid Window parameter)
Vim: Got X error
Vim: Finished.

This does not occur on my xorg-free server, so how can I force vim to behave as a console app?

[Edit]: I don't want to use X forwarding for a console app.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Have you tried the -X switch? This will disable the X integration features of Vim such as clipboard integration, so X is not needed to run it.

share|improve this answer
    
its a capital '-X' rather than the '-x' which edits an encrypted file, but it can be found by a simple vim --help. I just don't have my eyes in the right sockets today. –  brice Jan 31 '10 at 23:04
    
Yep, it's in man vim: manpagez.com/man/1/vim –  John T Jan 31 '10 at 23:05
add comment

DUH!

vim -X

will do it.

Moral of this story: RTFM RTFM RTFM. (or in this case vim --help)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.