Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I some how screw up my iterm configuration. Now I click the iterm icon, it shows the menu bar and icon on the dock, but it won't pop up any windows.

So I tried : * remove it from /Application and reinstall it. * remove the ~/Library/Application Support/iTerm

But that does not solve my problem.

Any other ideas please?

Thank you.

share|improve this question

migrated from stackoverflow.com Jul 21 '09 at 19:04

This question came from our site for professional and enthusiast programmers.

up vote 5 down vote accepted

Here's a quote from the iTerm page:

Where does iTerm store its settings?

Since version 0.8.0, all the setting is stored in ~/Library/Preferences/iTerm.plist. In case something goes wrong, you can delete this file and iTerm will generate a new settings file that should always work.

Quit iTerm before you delete the preferences file and when you restart, it should be OK.

http://iterm.sourceforge.net/faq.shtml

share|improve this answer

None of the other solutions worked for me. This is from the new FAQ page:

defaults delete com.googlecode.iterm2
share|improve this answer

iterm2 settings are stored in ~/Library/Preferences/com.googlecode.iterm2.plist. Removing that file will allow the program to reset to the defaults.

share|improve this answer

There may be a preferences file that also needs to be deleted, from the following directory:

~/Library/Preferences/

Not sure what it is called for iTerm, but it is likely to be something like:

com.company.iTerm.plist

Don't delete the whole directory, though!

share|improve this answer
    
BE CAREFUL don't delete the entire directory. To find the other files you need to delete, use an uninstaller like AppZapper. – Andrew Scagnelli Jul 21 '09 at 23:06
    
Yes, sorry I didn't make that clear! – Matthew Schinckel Jul 22 '09 at 3:35

I had some problems (it was hanging on a paste of one normal character), and the following rm solved it for me.

rm -rf ~/Library/Application\ Support/iTerm/
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .