Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A dreaful mistake lead to the following situation: Each and every one of my mouse buttons loads the Dashboard. I can't change the settings, not without using the mouse. It's a Catch 22.

How can I reset the mouse's settings, using Terminal, perhaps?

Help. Thank you.

UPDATE: I've disabled the Dashboard, using Terminal command line. But now the mouse is left functionless. I can't click on (almost) anything. At least not on anything I need.

share|improve this question
4  
How did you manage to set every mouse button to dashboard without considering the implications? :P –  Phoshi Jan 31 '10 at 23:25
1  
lol... totally awesome :) –  JT.WK Jan 31 '10 at 23:38
    
Sweet title. +1 –  Nathaniel Jan 31 '10 at 23:53
5  
You probably could have done fairly well with just the keyboard. ⌘-Space into spotlight. Type the name of whatever command you need to adjust the click settings (system prefs most likely, I need to use the logitech control center). Use keyboard to nav around enough to get a button working. Fix the rest. –  skarface Feb 1 '10 at 4:19
add comment

2 Answers

up vote 4 down vote accepted

I'm saved!

Simple solution to this awful catch-22 on Macs: If you have another computer, use Teleport to get control on the looped computer.

Three cons: 1) You have to have a second computer. 2) You have to have Teleport installed on both of them. 3) Teleport must be running on both of them while you're looped. Otherwise you won't get it started.

share|improve this answer
add comment

You can use the defaults command to remove your changes to default behaviour. defaults find mouse will, hopefully, list the relevant change, among others, then default delete com.apple.whatever (say) will delete a particular instance.

I've no idea how you got into this trouble: how did you configure this damned behaviour?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.