Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7 and the newest version of mozilla. when i try to install the add-on vimperator for firefox i get an error message:

Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/latest/4891/addon-4891-latest.xpi?src=developers

because: Unexpected installation error Review the Error Console log for more details. -203

i have restarted firefox and my computer but nothing seems to work, any suggestions?

share|improve this question
    
Can you install this add-on again, and open Error Console and see what's happened? –  hvtuananh Feb 1 '10 at 4:26
add comment

2 Answers

Try the version from the Vimperator website. And by "newest version of Mozilla", do you mean a beta release? I'm not sure about beta releases, but Vimperator works perfect with the newest Firefox stable release.

share|improve this answer
    
not beta releases, i have windows 7 ultimate and firefox is the most recent ve –  jay Feb 3 '10 at 3:39
    
not beta releases, i have windows 7 ultimate and firefox is the most recent version that is not beta, i believe it is 1.05? there are other problems that i am having with windows 7 as well, it does not recognize my integrated webcam, but the vimperator problem is really annoying –  jay Feb 3 '10 at 3:40
    
@Jay The most recent version of Firefox stable at the time of this comment is 3.6... –  John T Feb 3 '10 at 4:34
add comment

I hope you're not using Mozilla, but using Firefox?

The latest version of Mozilla Application Suite was 1.7, and that was back in 2005.
The suite lives on as SeaMonkey, but that's at version 2.0.2.

And the latest Firefox is 3.6, so if you've tried to install a recent extension on a Firefox version as old as 1.0 or 1.5, it definitely won't work.

I'm not on Windows 7, but on Windows XP SP3, Firefox 3.6 can install Vimperator 2.2 (October 28, 2009) just fine.

I've usually only seen error -203 when a network problem (or a firewall) has got in the way and prevented Firefox from downloading the XPI.

It may be that you have an old version of Vimperator which has become corrupted somehow. Or it could be that your Firefox profile is corrupted.

To test with a clean profile, try shutting down all Firefox windows, then start Firefox from the command-line with:

firefox.exe -P some-new-profile

...and then try installing Vimperator into that profile, to see whether it's a problem with your current profile, or some more general issue.

The "Help > About Mozilla Firefox" menu option will tell you which version you have.
The latest is 3.6, and the build id (shown at the bottom of the About Mozilla Firefox dialog) says

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.