Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a windows 7 computer running Xming 6.9.0.31. I connect to my linux box running Ubuntu Server 9.10 with plink and run urxvt. It starts up and works perfectly however the urxvt screen flashes the xming root window about twice a second. This makes urxvt impossible to work with.

Everything else that I have tested over the ssh connection (xterm, xfce4-terminal, etc) work perfectly with no flashing and this same problem has happened with two other linux installations (again only with urxvt).

Thanks!

share|improve this question
add comment

1 Answer

Did you install urxvt from the Ubuntu repositories? Which package? Or if you compiled it yourself, what compile-time options did you use? What features did you enable?

If you've installed via the Ubuntu repositories, try installing the rxvt-unicode-lite package instead of rxvt-unicode. The lite version is compiled with many of the extra features turned off, and may solve your problem without digging into all the various options.

urxvt aka rxvt-unicode has a lot of prettifying features built in. More than likely you're seeing a problem with one particular feature, and disabling it will fix your problem. In particular, try removing transparency/libAfterImage support, Xft fonts, and ... I don't know what else.

See the urxvt(1) man page for a list of runtime options. These jump out at me as good things to try turning off:

  • -rv - Turn off simulated reverse video; resource reverseVideo.
  • -tr - Turn off illusion of a transparent window background; resource transparent.
  • -depth - use a bitdepth that matches your X-server
  • -fade 0 - turn off fading-on-focus-loss

See the urxvt(7) man page (and urxvt FAQ) for a list of compile-time options (bottom of the page). If you've compiled your own, try compiling a new version with the --disable-everything option and seeing if that helps. If it does, you can add features back in and try them until you find the one that's causing the problem. In particular, these options turn off things that I'd expect to be sources of trouble:

  • --disable-transparency
  • --disable-afterimage
  • --disable-fading
  • --disable-frills
  • --disable-swapscreen
  • --disable-xft
share|improve this answer
    
Woah thanks for an awesome answer. I will try all that out when I get home. Cheers! As for your question, I installed from the Ubuntu repo's as rxvt-unicode. –  Carl Sverre Feb 2 '10 at 17:34
    
i've seen flickering issues like what you describe in other applications (a while ago; i don't use remote X much these days), and it always seemed to be an issue with some graphics feature that wanted to be running on real hardware to work right. try the rxvt-unicode-lite package, then if that fixes it you know it's one of the heavier graphics toys the regular package enables, and you can play with compile options if you like. –  quack quixote Feb 2 '10 at 20:55
    
So I tried it briefly and had problems with rxvt-unicode-lite. I will try and compile rxvt from source sometime soon with some of the disables you mentioned. Thanks! –  Carl Sverre Feb 3 '10 at 21:52
    
did you try the commandline switches i listed? no help there? –  quack quixote Feb 4 '10 at 9:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.