Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Vista Home Premium x64.

I wrote a program in Visual Studio 2008 I put it on my desktop.

Then, I deleted the program and changed the icon in Visual Studio and recompiled it.

Then I moved the program with the new icon from the output folder in Visual Studio onto my desktop.

The icon changed back to the old one. When I renamed the file, the icon changed to the new one again.

Why is this? (My hunch is that this is related to the search/indexing service...)

EDIT:

Ganesh's solution did not work...

EDIT 2:

How can I fix the icon(s)? In Diago's words: "How can I stop this from happening?"

share|improve this question
    
Please provide a more specific question. I am not sure if your asking for why it is happening or to stop it from happening? Bounty removed. –  Diago Feb 8 '10 at 10:24
    
@Diago - Why is this not a specific question? –  Moshe Feb 8 '10 at 14:44
    
My comments explains. WHat exactly are you asking, why it is happening, or how to stop it from happening? The first is not a specific question and will be closed, the second is acceptable but then it needs to be explained in the question. –  Diago Feb 8 '10 at 16:30
    
@Diago- better? –  Moshe Feb 9 '10 at 13:42

3 Answers 3

up vote 2 down vote accepted

Why is this? (My hunch is that this is related to the search/indexing service...)

It's because Explorer caches the icons for performance reasons and fails to figure out you've changed it. Been there... quite annoying.

I haven't found a reliable way to clear the cache - incidentally, you didn't state whether this is what you actually wanted to ask ;)

share|improve this answer

Try rebuilding the Windows Explorer Icon Cache Procedure here.

share|improve this answer
    
Didn't work. The author of that article said that his method may require multiple restarts - not something I call reliable. I tried it though. Thanks. +1 for effort. –  Moshe Feb 2 '10 at 13:29

I was able to replicate this problem on Vista Ultimate x64 SP2. Changing the desktop mode to 16- and then back to 32-bit fixed it immediately (no restart or logging off required).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.