Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Opera as my email client. When Opera finds some new mail it adds a tiny envelope to its system tray icon.

It disturbs me. How can I disable this notification?

share|improve this question
    
What version are you using? –  random Jul 22 '09 at 9:50
    
I use latest stable (9.64) on Linux. –  Tadeusz A. Kadłubowski Jul 22 '09 at 9:53

2 Answers 2

up vote 8 down vote accepted

This is a setting in the preferences:

  1. Ctrl + F12 or Alt + P

  2. Go to the Advanced tab, then Notifications.

  3. Uncheck Show notification for new messages

If you use Opera as an RSS reader, notification of fresh new feeds will also not be shown.

Elsewhere...

You may also need to edit the shortcut used to launch Opera in the first place.

For Linux, find the launcher and edit the properties to append -notrayicon, like so:

opera %u -notrayicon

Windows, locate the shortcut, right-click on Properties and append the target line with /notrayicon so that it will read similar to this:

"C:\Program Files\Opera\opera.exe" /notrayicon

In addition, you may need to do the following:

  • Right-click a blank area of the taskbar
  • Select Properties
  • Choose the Taskbar tab if not already selected
  • Customize... of Notification Area
  • Find the Opera icon and select "Always Hide" for its behaviour

When done with the above, close out Opera and then start it up again.

The Opera icon will now not show up in the system tray.

share|improve this answer
    
Actually this setting disables only annoying popup with extracted email headers. It doesn't disable changing system tray icon from ,,opera logo'' to ,,opera logo with a tiny envelope''. –  Tadeusz A. Kadłubowski Jul 22 '09 at 9:18
    
Added edit on how to remove for Linux. –  random Jul 22 '09 at 10:17

Enter opera:config into your address bar. Type "notif" into the filter box. Uncheck the notifications you do not want. Click on "Save".

share|improve this answer
    
For me, "noti" does the trick - adding a "y" at the end fails to match the notification preferences. –  patjbs Jul 21 '09 at 19:54
    
Oops. Corrected. –  innaM Jul 22 '09 at 6:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.