Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, this is a problem...

I have mounted samba volume and I need to have write permissions for every new folder that's being created (currently, by default, on every newly created folder i have only read and execute permissions).

I tried changing umask, but with no effect on mounted folder, umask changed only for local filesystem. I tried mounting with umask option, but with no effect again.

I'm using ArchLinux on this machine, and I installed samba using default package manager (pacman).

share|improve this question
up vote 0 down vote accepted

Default permissions on a samba volume is defined on the server side. I don't believe it is possible to override this from the client.

share|improve this answer
Yes, but on the server side, all folders are writeable (If not, I couldn't create new folders in a first place). So, I can create new folders (actually zoneminder is creating them), but I can't add files into them, until I manually change permissions for these folders. Manually changing is not an option, as zoneminder will try to write these files right after folder is being created. – Eedoh Feb 1 '10 at 11:26
@Eedoh: The person responsible for setting up the samba server has specified in the samba configuration file which permissions all new files and/or directories should have (in smb.conf: "create mask = xxx" and "directory mask = xxx"). When you (on the client) request to create a directory, it is the samba daemon on the server that actually does the creation, and it will use the permissions specified in smb.conf (on the server) regardless of what you configure on the client side. So I believe your best bet is to ask the sysadmin to change the server configuration. – Terje Mikal Feb 1 '10 at 11:46
You were right, it's necessary to change default mask on the server :) – Eedoh Feb 9 '10 at 8:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .