Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Sapphire ATI Radeon HD 2600 PRO graphics card in my Windows Server 2008 x64 machine. It has two outputs a VGA and a DVI. I have connected the DVI to my Dell 24" monitor with 1900x1200 resolution and it works 100%. The VGA I have connected to my second monitor a Samsung 22" with native resolution of 1680x1050. But the ATI driver and Catalyst control centre doesn't show this resolution as an option. If I choose a lower resolution like 1280x1024 it looks really bad and fuzzy. I searched in google and downloaded the powerstrip tool that allowed me to create a custom resolution of 1680x1050 and then this option shows up in Catalyst control centre and my 2nd monitor works fine now.

But I don't want to pay for an application to choose a display resolution. Why doesn't ATI show me that option by default even though it has no problem in actually supporting the display at resolution. Is there a way to get 1680x1050 resolution using ATI drivers only ?

share|improve this question
add comment

5 Answers

I had a similar problem with my 1680 x 1050 monitor.

I found that I had to use the "Desktops and Displays" section of the ATI Catalyst Control Center software and click on the "Detect Displays" button. Thereafter, it showed the 1680 x 1050 resolution as an option under "Desktop Properties".

share|improve this answer
    
I had to go to Desktop and Display > Display 2 > Configure and uncheck "[ ] Use Extended Display Identification Data (EDID) or driver defaults". After unchecking, I was able to force 1680x1050 as the maximum resolution for the monitor. This added it to all the appropriate dropdowns. –  Leons Mar 27 '12 at 14:30
add comment

Might be a driver issue with the drivers of the monitor. Either Windows uses wrong drivers for the monitor, or the ATI and the monitor drivers are incompatible in some way.

share|improve this answer
add comment

You may want to try the ATI Omega Drivers. I don't use them anymore since I'm using a Mac now, but when I did I think they came with a utility to help with resolutions. Of course, they are free.

share|improve this answer
    
From the "about" section on the site "I do this hobby in my spare time, since I have a personal life and a day work, so don't expect me to be up-to-date with everybody or everything..." That doesn't sound like a driver package that I'd want to install. –  MDMarra May 20 '10 at 1:10
    
When I was running I had no troubles whatsoever. Didn't notice any difference in performance, either. They're easy to uninstall if it doesn't work. Worth a shot if nothing else is working. –  donut May 21 '10 at 4:01
add comment

You need the old drivers. No new ones work. CATALYST file version 3.0.741.0, released in 2009, has the correct drivers.

I had a lot of problems, but that was the solution.

share|improve this answer
add comment

For me the fix was in AMD catalyst control center, set properties VGA Display. I had to set the max resolution to 1680x1050

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.