Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is really a question about whether or not it is absolutely necessary for me to upgrade my Fedora.

I just upgraded my computer with a couple more sticks of RAM and have it up to 8G now. I duel boot so I know that Vista (64bit) recognizes my 8G, and Memtest86+ recognizes my 8G, but for some reason Fedora 9 (64bit) says it has 3.1 G RAM. Is this a problem with Fedora 9 (64bit) or is it some configuration thing I've missed?

share|improve this question
3  
Since Fedora 9 is no longer supported, I'd strongly suggest that you update regardless. See fedoraproject.org/wiki/Releases –  developmentalinsanity Feb 1 '10 at 13:49
    
I know I should, but i want to know if I need to in order to get all my RAM. –  Robbie Feb 1 '10 at 14:25
add comment

2 Answers

up vote 1 down vote accepted

Just re-download a kernel and re-compile it, including 64GB RAM support. Your kernel is just not supporting more than 4 GIGs right now.

share|improve this answer
    
Is there something special I need to do in order to include 64GB RAM support, or is that just dependent on the kernel that I download? Should I get the latest kernel (2.6.32.7), the kernel that I am running (2.6.27.25), or the latest sub version of the kernel that I'm running (2.6.27.45)? I don't want to break my existing install. –  Robbie Feb 1 '10 at 17:04
    
All kernels have the option available. It's a matter of selecting it. Sadly, I have never compiled my own kernel in Fedora and do not know what specific steps you need to take in order to not break any automation - but on that level, Google can help! If you're lucky, you may already have the source for the kernel available - for me, with Gentoo, they are under /usr/src but I am not sure where they are for Fedora. You may be able to get them from yum. If you compile a kernel that doesn't work -- just boot from the old kernel! –  Trevoke Feb 1 '10 at 17:17
    
Thanks, I'll give it a shot and give you a check if all goes well. –  Robbie Feb 1 '10 at 17:19
    
I couldn't find the option for 64GB support in gconfig with the 2.6.27 linux kernel. I'm going to try again tonight, though I couldn't really find any good sources of information about that particular config flag. –  Robbie Feb 2 '10 at 14:37
    
Here, take a look at this article. I hope it helps: linux.com/archive/feed/119287 At the worst, you may need to patch the kernel (easier than it sounds) or download a pre-patched / custom kernel (safer than it sounds). –  Trevoke Feb 2 '10 at 18:33
add comment

You can also install a 32 bit Linux, and install the bigmem kernel. Then supports 64 GB ram on a 32 bit system (if CPU >= Pentium 4)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.