Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I installed emacs this error occurs every time on startup. It prevents me from installing plugins, e.g. auctex via aptitude. I already tried to install a plugin by hand (rails for ruby), but doesn't work.

The error doesn't contain the message "hostname", but the hostname of my PC is displayed ("bloodredangel-ubuntu"). I changed my hostname to "bloodredangel", but the error message stays the same. While I changed my hostname I saw that in /etc/hostname were two entries:

127.0.0.1
bloodredangel-ubuntu

I already asked this question in an ubuntu forum but they couldn't help. They recognised an misconfigured /etc/hosts file, which I corrected, but from time to time these incorrect configurations get attached by something. I didn't add them by hand, maybe it has something to do with the issue. The misconfigurations looked like this:

127.0.0.1             127.0.0.1
bloodredangel-ubuntu  localhost.localdomain  localhost
127.0.0.1             127.0.0.1:8080
bloodredangel-ubuntu  localhost.localdomain  localhost

I didn't found a solution on the internet, so I hope I will find help here finally.

share|improve this question
    
you can try running emacs with the --debug-init option, which will hopefully give you a more meaningful stack trace – user84207 Mar 18 at 6:18

Try adding (setq hostname "bloodredangel") (or whatever other hostname you want to set it as) to the beginning of your .emacs file.

share|improve this answer
up vote 0 down vote accepted

"Solved" it by reinstalling Ubuntu. Was less work than expected. (Backupped the home folder, so reinstalling took approximately 4h with making an backup and playing it back.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .