Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently my Windows 7 64-bit PC has started waking every night from hibernation around 3:30am. I have done the following to try and figure out what is causing the issue with no luck:

  • Examined the Windows Event logs. Nothing is noted
  • Ran powercfg -lastwake and that reports nothing

  • c:\powercfg -lastwake

  • Wake History Count - 1
  • Wake History [0]
  • Wake Source Count - 0

Ran powercfg to find what devices are armed for wake. Interestingly, this reports two items (I've already unchecked the "Allow this device to wake the computer" in device manager): The keyboard and something called the "eHome Infrared Receiver (USBCIR)". This is a desktop PC and it does not have an Infrared received, so I'm not sure what that device is. Suffice to say it does not have the option to "Allow device to wake..." available in Device Manager.

  • C:\powercfg -devicequery wake_armed
  • eHome Infrared Receiver (USBCIR)
  • HID Keyboard Device

My next step is to disable the Keyboard from wake, but I'm not convined that's the problem.

This is on a Dell XPS435 if that helps anyone.

share|improve this question

migrated from stackoverflow.com Feb 1 '10 at 16:24

This question came from our site for professional and enthusiast programmers.

    
Is it possible that you have "Wake on LAN" enabled in your BIOS? –  Michael Todd Feb 1 '10 at 18:45
3  
HID Keyboard Device: Do you own a cat / other roaming, nocturnal pet? –  user12889 Feb 2 '10 at 2:22
    
Why not just unplug the keyboard ? And the mouse ? –  ldigas Mar 5 '10 at 18:13
add comment

10 Answers 10

I had the exact problem like the OP, Win7 32Bit, PC hibernation and it woke up at 3:57am precisely every night, but there was nothing noted in the log and the powercfg -lastwake gave no information.

The problem was the Windows Media Center. Once, I even caught it red-handed downloading some updates right after the PC woke up, so I disabled the auto-update in the settings. So when the problem persisted I wasn't thonking of the WMC as the culprid anymore.

But it turned out that even though I turned it off within the WMC, the task within the Task Scheduler was still up and running. To disable the task simply open the Task Scheduler, navigate to Task Scheduler Library\Microsoft\Windows\MediaCenter. There should be the mcupdate_scheduled task. Disable it – problem solved!

share|improve this answer
1  
Or configure the task to not wake the computer –  mousio Dec 15 '12 at 10:32
    
Disable sleep timers in power configuration is a better option. You may disable this only to find another task is waking your computer at another time. –  Dermot Sep 19 '13 at 14:34
add comment

I was having exactly the same issue of my laptop waking up after 6 hours of sleeping. I have found that the cause of the issue in my case was the advanced power settings for hibernation, which was set to hibernate after 360 mins (6x60min) of inactivity.

How to check and disable:

  • Go to Control Panel → Power Options → Change plan settings → Change advance power settings.

  • You will get "Power Options", where you have to navigate to "Sleep → Hibernate after" and disable hibernation for both "On battery" and "Plugged in" modes by changing the default value from 360 to 0.

share|improve this answer
add comment

That sounds like the Windows Updates.

share|improve this answer
    
I disabled Windows Updates adn that did not help either. –  DavidGugick Feb 17 '10 at 19:27
add comment

You say "around" 3:30. Can you determine if it is happening at exactly a given time?

Also, try looking at the scheduled tasks in the task scheduler MMC plugin - there may be something set to run there.

share|improve this answer
add comment

I know you mentioned looking into the Event logs, but what have you seen in there? At the very least, you should get an idea of WHEN it wakes up. That may point out a Scheduled Task, or as Bobby points out, a Windows Update resumption.

share|improve this answer
add comment

Interestingly, my Windows Updates are set to check at 3am. The first event I see in the Windows System event log is always around 3:15am and it's the system time being checked. There is an event in there from the Power-Troubleshooter service that indicates the PC has awaken from sleep (really hibernate in my case), but indicates the Wake Source is "Unknown", which jives with powercfg.

I will move Windows Update from 3am to 6am to see if that's it, but even if it is, it wasn't causing the problem for the last 6 months. Maybe a Windows Update. I thought it might be related to NIS 2010, but cannot see anything scheduled by that program or any other in Windows Scheduled Tasks that is running at that time.

As far as wake on LAN in the BIOS, it's probably set if available, but the network card is explicity set to not wake from sleep in Device Manager.

share|improve this answer
    
Still no luck here. I found a post on Win7 and the Realtec ethernet cards (jack.ukleja.com/…) and that did not help. Then I tried pulling the ethernet cable from the PC and it still woke up. Powercfg reports only that it woke up but not the process and, again, the event logs are bereft of information. I even tried disabling the wake_armed flag of the "eHome Infrared Receiver (USBCIR)" device and that did nothing. Any ideas. I'm out of them. –  DavidGugick Feb 17 '10 at 19:25
add comment

I had the exact same problems with the exact same symptoms. I looked at the scheduled tasks and did not see any task that was configured to wake the system up for execution.

I started Google Updater and configured it to never update Google software.

Since then the system has not woken up by itself. Its only been a day, so it may have been a fluke. If it works in the long run then it obviously raises the question of why would Google updater wake up the system when it was clearly configured not to do that in the scheduled tasks.

share|improve this answer
add comment

I had a similar problem, and discovered the culprit: after being asleep for 6 hours, my computer wakes up and goes into hibernation. Since my computer usually falls asleep shortly after I go to bed, it kept waking me up when I was in the middle of sleeping. More here (including instructions on how to disable).

share|improve this answer
add comment

I solved this exact problem! I found that what woke my computer was a service of Windows Media Center scheduled to start at night (about 3.30AM) with option "wake computer if needed" . this scheduled operation became active after i've installed a TV tuner... before i never used WMC...

Go in scheduled tasks of windows (Start > All Programs > Accessories > Systems Tools > Task Scheduler) Expand Microsoft->windows->MediaCenter . You will find an item called MC_update_scheduled . Doubleclick on this item and change the options to start the task at computer startup or uchecking the option "wake the computer if needed" (in the conditions tab) .

Hope this help!

share|improve this answer
add comment

I had used Task Scheduler to turn this off too i.e. Media Centre Upadte. However last night, I noticed it woke up at 3AM (and hence woke me up too) after a break of a few months.

Apparently the new culprit is Windows Defender, scheduled to wake up at 3AM, this does appear to be a recent development, maybe a Windows 7 update did this?

To stop this, click the start Orb, type "taskschd.msc" in the search box at the bottom. Within the Task Scheduler, open the "Task Scheduler Library" tree branch, then the "Microsoft" branch, select "Windows Defender" and then double click on the "MP Scheduled Scan" entry in the top centre window pane.The rest is self explanatory, i.e. changing its run time. Alternately don't double click it, right click and disable it.

Don't forget to disable or modify the Media Centre Update entry (As per soandos's answer above) if you haven't done so already.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.