Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My flex builder somehow decided to create infinite folders within folders and crashed itself. Now windows cannot delete the folder, saying the file name is too long. Even Unlocker can't delete it.

The folders are created like this:

projectname-debug -> projectname-debug -> projectname-debug -> ..........
share|improve this question
    
Have you tried deleting it while running Windows in Safe Mode? –  Ivo Flipse Feb 1 '10 at 18:26

4 Answers 4

up vote 10 down vote accepted

Boot up some linux live distribution and delete it from there.

share|improve this answer
11  
Then stay in linux. –  Josh K Feb 1 '10 at 18:48
    
And what if he's programming in Visual Studio? –  Ivo Flipse Feb 1 '10 at 18:49
2  
I never said it was practical. ;) –  Josh K Feb 1 '10 at 18:57
    
@Ivo: then use WINE... –  quack quixote Feb 1 '10 at 21:57
    
@Ivo: I'm using Flex Builder 3, an Eclipse plugin @Josh: Bingo... did just that. I happened to have Ubuntu installed. Cheers mate! –  gAMBOOKa Feb 2 '10 at 0:13

You might try using the SUBST to map a long path to a new drive letter. That may get the path down short enough for you to delete some of the lower directories first.

share|improve this answer
1  
Nice! That works great. In fact, it gave me the idea of renaming the parent directory/directories to shorter names which also works. –  Bobson Nov 21 '11 at 2:56

Try the command line:

rmdir /s /q "C:\path\to\folder"
share|improve this answer

I've had a similar issue due to a screwed up subversion checkout. What I found worked was going in as deep as you can and the move the contents out. You should then be able to delete the outer part. Repeat the process with the stuff you moved out. Worked for me, but it might not be exactly the same situation.

share|improve this answer
1  
Windows will stop traversing inside the folders after a while. I used rm /s and it removed all the contents inside the folders, but the folders itself won't go away. –  gAMBOOKa Feb 1 '10 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.