Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my Media Center PC from XP MCE to the Windows 7 RC to make sure there wouldn't be any problems. Well, in addition to updating the software, I figured I'd implement my plan to use a share on my NAS (mapped to a drive letter for my convenience) to house my library as that made synchronization/backups/etc. easier. Especially since I've added a couple other MCE computers around the house...

Anyway, despite adding the drive letter as a part of my library, the Media Center software won't add the MP3s to the library. Windows Media Player will play the music (so I know its accessible, etc.) but it also won't add it to the library. (I kinda figured they shared a library, but it was worth checking)

I've seen from ye ole Google that others are having this problem, and it was a problem in Vista's Media Center software as well - but I couldn't find a solution that didn't involve synchronizing a local directory with the NAS...

FWIW, I'm running the 64-bit edition. Somehow I don't think that matters though.

share|improve this question

5 Answers 5

After trying all these convoluted (but smart) ways of adding the music files to the library to no avail (probably due to my in-experience with the command prompt syntax), I finally went into my music folder, highlighted all of the music folders by using Cntrl+A, right clicked, and told it to add to a playlist. After windows media player plays a song from the playlist, it adds it to the windows media player library and then also shows up in the Windows Media Center Music Interface.

UPDATE: It actually starts to populate your database right away. After right clicking and adding to playlist, it will start to play the songs but also add them in the background. It doesnt wait until the end of the song.

share|improve this answer

Apperently in Media Center, you can add a directory (even network shares) to a Windows 7 library.

It's hidden in the wizard for the advanced setup.

share|improve this answer
    
Been through the advanced setup many many times. The network share needs to be indexed - the NAS wasn't doing it. –  AnonJr Feb 7 '10 at 6:29
    
When you are in Media Center, you can adjust the folders under 'tasks'. –  Ton Plomp Feb 11 '10 at 7:55
    
I know - that's where I was. If the source isn't indexed WMC fusses at you and refuses to add it as a source. Or at least it did when I first posted. Maybe there's been a patch since then. Ramping up the storage in my Media Center has still turned out to be the best option - for the simple reason that I can also run Carbonite in the background and sleep a little better. –  AnonJr Jan 3 '11 at 11:36
    
After installing SP1 for Windows 7, I can add folders to libraries direct from windows media player. It looks like it's working now for me. –  Ton Plomp Mar 3 '11 at 8:24
up vote 0 down vote accepted

Couldn't add the NAS to the home group, symbolic links were beating the snot out of my NAS - and it still took a day for new material to be added to the library... so I put a 1TB drive in the Media Center and am now using that as the share. Makes using the laptops in the kitchen and bedroom as extenders easier too.

share|improve this answer

From what I've found:

The easiest solution I have found to getting your files to show in the Windows 7 Media Player library is a trick I used before in Vista.

Start a command prompt as administrator

In your C:\Users\XXX\Music directory, use the mklink command to create a directory symbolic link e.g.

C:\Users\Alan\Music>mklink /d Alan \ANP-CUBE\music\Music\Alan symbolic link created for Alan <<===>> \ANP-CUBE\music\Music\Alan

After that I simply navigated through the link in explorer to a music file and chose Play.

Windows Media Player started up, played the file and also started populating the library with all my music files

I have done the same with the Public directory for files I share with my wife:-

C:\Users\Public\Music>mklink /d Public \ANP-CUBE\music\Music\Public symbolic link created for Public <<===>> \ANP-CUBE\music\Music\Public

I think the solution would be to add your NAS to a Home Group.

According to this post it should just work, but then again it's from Microsoft itself ;-)

share|improve this answer
    
I mucked around with the Home Group stuff for a while last night without much joy, but it looks like the Symbolic link may have done the trick. If I get home tonight and find media in my library, you sir, will get a star. :) –  AnonJr Jul 23 '09 at 14:36
    
Well I hope you get it working! For me it's good to learn how to do these kind of things ;-) –  Ivo Flipse Jul 23 '09 at 14:46
    
Almost worked... If I play it in WMP, it gets added - but it crashes every time it tries to index anything else. :( –  AnonJr Jul 25 '09 at 13:26
    
making a directory mklink to my network share worked directly –  Ton Plomp Jan 7 '10 at 19:25

It's a know issue (bug?) since Vista that has not been addressed or at least fixed.

share|improve this answer
    
Figured that... was hoping someone had a workaround that didn't involve scripting and a scheduled task. –  AnonJr Jul 21 '09 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.